Por Jurion
Novato
Autor del hilo
#86419
Hola, tengo el H96 Pro+ con una conexión de 300/300 por ethernet.:

OS: Android 7.1 OS

CPU: 64 Bits Amlogic 912 Octa-Core [email protected]

GPU: ARM Mali-T820MP3 GPU up to 750MHz (DVFS)

RAM: 3GB DDR3

Flash:32GB EMMC

Codecs de vídeo: VP9-10 Perfil-2 hasta 4Kx2K @ 60fps, H.265 HEVC [email protected] hasta 4Kx2K @ 60fps

LAN Ethernet: Up to 1000M

WiFi: WiFi 802.11b/g/n ,dual band 2.4GHz/5GHz


Tengo el Kodi 17.4, con la aceleración por hardware activada y modificado el tema del buffer como explican en muchos tutoriales de internet. El caso es que cuando reproduzco archivos en streaming de 1080p, me pasa siempre lo siguiente:

a) Puede que empiece y se congele la imagen, escuchándose el sonido, avanzando los segundos. A veces cuando lleva 1 min ó así, se arregla y se ve bien. Desde ahí sin problema.

b) También puede que se queda la pantalla en negro con el dibujo de carga en 0, pero no carga o carga lentísimo. La mayoría de veces se queda ahí.

Lo extraño es que avanzo el título y se ve y escucha perfectamente, y la carga de buffer es rápida.

He pensado que pudiera ser problema con el codec h265 (no he probado a reproducir en local), o que pudiera ser saturación del servidor de streaming. Pero si fuera lo primero, no me reproduciría el título directamente, y si fuera lo segundo, no pasaría sólo al principio y lo haría en todo el título. Ya digo que si avanzas el título, carga y se ve perfecto a partir de ahí. No obstante sé que el addon reconoce que tiene muchos problemas de saturación, pero que sólo pase al principio de los títulos en 1080p es raro.

¿Qué podría ser?

Muchas gracias y un saludo.

Avatar de Usuario
Por Tocinillo
Administrador
#86434
Yo creo que es por Android, que sigue yendo como el c&&%, si quieres un consejo pásate a LibreELEC y verás la diferencia.
Jurion le gusta esto

Por Jurion
Novato
Autor del hilo
#86475
Hola Tocinillo, gracias por responder.

He estado investigando un poquillo y he intentado cambiar el método de renderizado de por defecto a por software, pero sorpresa, esa opción está sombreada y no se puede cambiar. Parece ser que los Amlogic tienen esa opción capada en Kodi.

Después he intentado actualizar del 17.4 a la última versión 17.6, para ver si solucionaba algo el problema o me dejaba cambiar el renderizado, pero sopresa desagradable otra vez. Ni se puede actualizar desde el Play Store, ni te deja instalar encima el apk bajado de la página oficial. Se ve que tendré que desinstalar y hacer una instalación limpia. Cagon la leche, ahora que acababa de terminar de configurarlo y meter los addons que más me gustaban...Sé que para alquien avanzado, no es tanto jaleo, pero yo soy noob total y llevo con el cacharro 2 semanas.

He hecho con el Backup una copia de seguridad, ¿se puede desinstalar la versión 17.4, instalar la 17.6 y luego restaurar la configuración y los addons de la copia de seguridad de la 17.4?

Había oído lo del LibreELEC. Habrá que echarle una ojeada más detenidamente. Supongo que se podrá tener con el Android, ¿no? Por lo menos hasta problarlo.

Muchas gracias.

Por -ice-
Maestro
#86486
Puedes ponerlo en un pen y bootear desde un USB.
Lo mismo, si lo usas sólo para Kodi, es lo mejor que puedes hacer.
Android es un PÉSIMO SO para multimedia.
Jurion le gusta esto

Avatar de Usuario
Por Tocinillo
Administrador
#86492
Coincido ;)
Jurion le gusta esto

Por Marlos
Novato
#90517
Tocinillo escribió:Yo creo que es por Android, que sigue yendo como el c&&%, si quieres un consejo pásate a LibreELEC y verás la diferencia.

Hola Tocinillo,acabo de ver este post que es muy parecido a uno q puse el año pasado por aquí,cuando aun estaba con Android. Me pasé a libreelec,y es otro mundo. Tanto en la fluidez de los menús como al ver vídeos. Pero a la hora d ver películas,la mejor calidad q podía ver era microHd(4-8 gbs), En cuanto ponía una de 10gbs o más. Se me paraba al poco de iniciar por el buffer. Teniendo buen configurado el advanced settings,me dio por mirar la info del sistema,y resulta q solo tenían 9 gbs libres,ya q es un aparato de 16gbs. Con lo q lógicamente,no podría Bernard pelis de más de 9 gbs.
Ahora bien,cambiè la configuración del quasar,q es el q uso siempre para pelis y series,poniendo la carpeta de descarga en el disco duro externo q tengo conectado al tv box. El disco es de un Tb,así q por problema de espacio ya no es...pero aun así,me sigue pasando lo mismo. No tira el buffer por el a en pelis a partir de 10 gbs mas o menos. Habrá alguna configuración q se me escape?? O directamente es imposible ver una peli a 1080p ( Full Hd) en un tv box (Supongo q de 4k,ya ni hablar) ,aun teniendo libreelec?? Gracias y un saludo...

Por -ice-
Maestro
#90533
En Quasar debes especificar el DD cómo directorio de descargas y asegurarte que lo usa.
Hay varios post que explican cómo hacerlo. Especialmente si tienes Android 7 y superior.

El tema con los 4K es el tamaño del archivo. Si tú quieres ver una peli que dura unas dos horas y Quasar (por conexión o por falta de seeder) tardará tres horas en bajarla, no podrás verla. En realidad sí podrás. La pones a bajar una hora y media y ya la puedes empezar a ver.

Por Arturo1971
Novato
#90561
Hola roliverosc (Maestre). A mi me pasa lo mismo con l'ós archivos .mkv con el addons palantir que és el que me funciona mejor. Tengo una màquina minix Neo uh-9 de 2 gb de ram con Cadí 1 gb llibre. Instalado el addons ttbuffer y a lo primero notes algo tanto en mkv como peliculas 4k no se me parava en streaming. Ahora se me para O no comienza. Puede ser problema de abrir algun puerto en el router. Ah tengo fibra de 50mb y el minix considero que és un buen Smart boc
Por favor ayudadme
Gracias

Por Marlos
Novato
#90564
-ice- escribió:En Quasar debes especificar el DD cómo directorio de descargas y asegurarte que lo usa.
Hay varios post que explican cómo hacerlo. Especialmente si tienes Android 7 y superior.

El tema con los 4K es el tamaño del archivo. Si tú quieres ver una peli que dura unas dos horas y Quasar (por conexión o por falta de seeder) tardará tres horas en bajarla, no podrás verla. En realidad sí podrás. La pones a bajar una hora y media y ya la puedes empezar a ver.


A ver,igual este no era el mejor sitio para mi pregunta,porque es un tema sobre android,y yo estoy hablando sobre libreelec. Escribí por aquí,porque justo hace un año puse un post parecido,de lo mal q me iba con android. Desde entonces,estoy con libreelec,q va como un 900% mejor q android. Precisamente viendo lo bien y fluido q va todo,me extraña q no pueda con pelis de 10 gbs o mas. El quasar lo tengo configurado para descargar en el disco duro,eso si,las otras dos opciones del quasar si las deje como estaban (el directorio de la biblioteca y no me acuerdo cual es el otro). Pero el importante para lo del buffer,q si no me equivoco,es el directorio de descargas y ese está puesto en DD externo. La cuestión,es por que teniendo espacio de sobra en el disco duro,y unos 1300 megas de memoria libre más o menos(según el kodi,el sistema no usa más de 700 mbs al arrancar),en cuanto quiero ver por quasar una peli de 10 o 12 gbs,el buffer no puede con ella.
Lo del 4k era por decir algo. No me hace falta poder ver 4k online,ni tan siquiera,un full Hd (1080p)de estos de 20 o 30 gbs. Pero últimamente,hay menos pelis en microHd (m1080),y a veces la única opción es una 1080p de más de 10 (y menos de 20) gbs. Entonces es cuando pruebo a poner esa opción,q es la única opción q me qda,y ya digo q a los 10 segundos o así ya se me para por el buffer y así se qda. Entonces lo q hago,es lo q dices,al cerrar el quasar le digo q siga descargando y al tener el directorio de descarga en el dd,pues ya lo meto a las carpetas q tengo de siempre para descargar pelis, y después ya la veo una vez q descarga. En el ordenador no he probado,pero me imagino q se podrá ver todo perfectamente. Lo q no entiendo es q me pase esto,Tendiendo espacio de sobra y con libreelec q va como un tiro. Ah!! Mi conexión a internet es de 300 mbps de Telecable. Desde el kodi,haciendo tests de velocidad,siempre me salen unos 80 Mb/s,q no son los 200 y pico q me llegan al Pc,pero más q de sobra para q me tire por lo q sea. Por eso preguntaba,si hay gente,q teng a un tv box con libreelec ( me imagino q con android será imposible)y q vea con el quasar pelis de mas 10gbs. Y si es así,q alguien me explique como!!!Gracias

Por -ice-
Maestro
#90566
Yo las veces que he visto archivos de más de 10GB lo he hecho sin problemas. Tengo 50Mb/s simétricos. Lo único que hago es dejar que se estabilice la descarga. Empieza bien y sube rápido, luego casi siempre baja hasta 1 o 2 KB y luego de unos minutos ya sube hasta la capacidad máxima de la línea y ahí se queda hasta el final. Siempre hablando de archivos con fuentes suficientes.
Si las descargas se guardan en el DD y éste tiene lugar, una vez que se inicia Quasar no debería tener más problemas.
Otra cosa es si no hay un flujo de datos constante y suficiente (lo de los sedders que te comenté).
Cuándo inicia Quasar y empieza a visionarse la película, ¿A qué velocidad baja? ¿Es constante?. Lo ves pulsando PAUSE en la notificación que aparece en medio de la pantalla.

Por Marlos
Novato
#90571
-ice- escribió:Yo las veces que he visto archivos de más de 10GB lo he hecho sin problemas. Tengo 50Mb/s simétricos. Lo único que hago es dejar que se estabilice la descarga. Empieza bien y sube rápido, luego casi siempre baja hasta 1 o 2 KB y luego de unos minutos ya sube hasta la capacidad máxima de la línea y ahí se queda hasta el final. Siempre hablando de archivos con fuentes suficientes.
Si las descargas se guardan en el DD y éste tiene lugar, una vez que se inicia Quasar no debería tener más problemas.
Otra cosa es si no hay un flujo de datos constante y suficiente (lo de los sedders que te comenté).
Cuándo inicia Quasar y empieza a visionarse la película, ¿A qué velocidad baja? ¿Es constante?. Lo ves pulsando PAUSE en la notificación que aparece en medio de la pantalla.


Es decir,tú cuando abres una peli con el Quasar,la pausas al principio y la dejas descargando un rato??? No te sabría decir en este momento,la velocidad según empieza la peli,porque tengo desactivada la opción de ver la barra de progreso,porque en las pelis estaba un rato viéndose y molestaba. La volveré a activar para fijarme en la velocidad. Lo q si te puedo decir,es q a la hora de cargar la película,es decir cuando sale la ventana de descarga de quasar,antes de q la película empiece ,va subiendo de velocidad poco a poco,pero por ejemplo,una película en m1080p, de 5 gbs,tardará en cargarla 10 segundos como mucho. Y en esos 10 segundos pasa de descargar de 0 a 4-8 Mb/s. Es decir,bastante bien creo yo. Mi conexión ya comenté q es de 300 Mbps,de fibra optica(con Telecable). Eso quiere decir q podría descargar a 37 Mb/s. A mi tv box de la conexión de 300 mbps, me llegan unos 80,lo q quiere decir q podría bajar como mucho a 10 Mb/s,así q si llega hasta casi 8 a veces,más no puedo pedir a la conexion( ni tampoco creo q haga falta). Lo q no entiendo es lo q comentas tú de tu conexión. Es de 50Mbps??? O de 50 Mb/s? O sea entiendo q es una de 400 Mbps( megabits por Segundo) y descargas a 50 MB/ s( Megabytes por Segundo) como máximo???
Y otra cosa. Si lo q haces es pararla un poco al principio para q cargue,no es lo mismo q cambiar en los ajustes el prebuffering?? Es decir,yo ahora lo tengo puesto en 60,y entiendo q es un % del total,tú ahí eliges cuanto quieres q descargue el quasar d la peli,antes de empezar a verla no?? Es decir,por lo menos en el torrenter,si ponías un 40,lo q hacía era descargar un 40% del archivo antes de abrirlo.
De todas formas yo lo q preguntaba es si hay gente q en el Kodi con libreelec,vea películas de mas de 10Gbs sin hacer nada. Es decir,abrir el archivo y sin hacer nada,q se vean bien y fluidas sin q paren por culpa del buffer. Hablo de verlas con quasar,lo de palantir y demás no me interesa mucho. En palantir hay pelis en 4k q puedo ver online,y otras de hd q se paran cada poco por el buffer. Me parece más inestable y menos fiable. Yo me refiero al quasar q me parece la mejor opción para ver pelis con buena calidad. Y si no,podría ser tema de tener q abrir puertos? Porque eso si q no lo he hecho. Lo único es q puse la ip del tv box como fija,pero no abrí ningún puerto,la verdad....
Gracias y un saludo

Por -ice-
Maestro
#90578
"50Mbps??? O de 50 Mb/s" Ésto es lo mismo. Son 50 Megabits por segundo. Que vienen a ser unos 6000KBps o 6000KB/s. KiloByte/segundo.
Velocidad más que suficiente para ver cualquier archivo.
Lo que te decía es que yo lanzo el Quasar y cuándo empieza la película (entre 10´ y un par de minutos, depende) la pauso y dejo que se descargue un porcentaje de alrededor del 10%. Recién ahí la empiezo a ver. No conozco en Quasar la opción de indicarle que empieze a reproducir una vez descargado xx%.
Habilita en las opciones la notificación y cuándo pongas pausa te aparecerá en el medio de la pantalla la información de la descarga.

Por Marlos
Novato
#90598
-ice- escribió:"50Mbps??? O de 50 Mb/s" Ésto es lo mismo. Son 50 Megabits por segundo. Que vienen a ser unos 6000KBps o 6000KB/s. KiloByte/segundo.
Velocidad más que suficiente para ver cualquier archivo.
Lo que te decía es que yo lanzo el Quasar y cuándo empieza la película (entre 10´ y un par de minutos, depende) la pauso y dejo que se descargue un porcentaje de alrededor del 10%. Recién ahí la empiezo a ver. No conozco en Quasar la opción de indicarle que empieze a reproducir una vez descargado xx%.
Habilita en las opciones la notificación y cuándo pongas pausa te aparecerá en el medio de la pantalla la información de la descarga.

Con lo de la velocidad de descarga quería diferenciar bits de Bytes. Digo q mi conexión es de 300 megabits por segundo,q al pasarlo a bytes serían 37,5 Megabytes por segundo,q sería la velocidad máxima de descarga. Aun asi,aunque al pc si q m llegan los 300( o un poco menos) en los test de velocidad q hago desde el kodi,siempre me sale una velocidad de conexión de 80 megabits por segundo o un poco más,q vienen a ser unos 10 Megabytes por segundo de velocidad de descarga,q en resumen creo q es más q suficiente para que vaya perfecto. Yo esto lo descarto.
Ayer hice una prueba activando la opción de Quasar,para poder ver el Progreso de la descarga mientras veo el vídeo,y probé con una peli de 20 gbs. Según empezó a verse la peli,la descarga iba a unos 4 MB/s y nunca bajo de los 2 MB/s,q no se si es lo suficiente para q se pueda ver una peli de 20,o aunque sea 10 gbs. Lo digo para poder entender dónde está el fallo.
La opción a la q me refiero de quasar es la opción de Buffer,q también la tiene en el torrenter. El valor por defecto en Quasar creo q son 40,y eso significa q cuando se abre el archivo de video y sale el cuadro de diálogo de quasar,en el q se ve la velocidad,los seeds,y la barra de progreso,antes de q se empiece a ver el vídeo,lo q hace es estar descargando esos 40 megas,antes de empezar a ver la película. Ayer probé a poner 150,q es una burrada,y aunque tardó un montón en empezar a ver la peli,en cuanto empezó,al minuto o así,la película se qdaba pausada. Probaré a hacer lo q tu dices,pero de todas formas,yo me refería a si se sabe de alguien q las pueda ver sin hacer nada. Yo ya digo q las de MicroHd (1080p) de hasta 8 gbs,las veo perfectas,y no necesito mas calidad de imagen,pero cada vez hay menos,y a veces no tengo la opción de el microHd,y realmente no entiendo el problema para q no se puedan ver. Los q usen Kodi con el pc,me imagino q no tendrán problemas,y los q usen tv box con Android( como yo el año pasado) lo tendrán muy difícil,pero con libreelec,con un montón de memoria libre( mientras se reproduce una peli,no pasa ni del 45% de consumo de memoria),con una velocidad más q aceptable de conexión,y con unos 300 gbs libres de espacio,ya q lo tengo en el DD,de verdad q me tiene loco no saber dónde está el problema...

Por -ice-
Maestro
#90605
Aclarado lo de la velocidad de descarga, creo que es más que suficiente para ver cualquier archivo con las fuentes adecuadas.
A ver si entendí bien. Cuándo pones pausa, ¿Sigue descargando a ésa velocidad?

Yo no le he comentado, pero mi LE corre en una RPi3 y el directorio de descarga está en un DD externo.

Temas similares
Temas Estadísticas Último mensaje
Problemas con reproducciòn
por pablovc  - 03 Nov 2018, 19:07 En Add-ons Kodi
0 Respuestas
266 Vistas
por pablovc
03 Nov 2018, 19:07
Nueva grafica para H265/HEVC 10bit
por humberthx  - 19 Nov 2018, 17:33 En Hardware
3 Respuestas
386 Vistas
por -ice-
20 Nov 2018, 17:52
Reproducción lenta
por zemonhas  - 18 Feb 2018, 16:38 En Mac OS X
0 Respuestas
624 Vistas
por zemonhas
18 Feb 2018, 16:38
Velocidad de reproduccion en kodi
por Feagorone  - 13 Mar 2018, 05:12 En Android
1 Respuestas
753 Vistas
por Feagorone
14 Mar 2018, 04:20
Reproducción de lista abortada
por frankncorral  - 15 May 2018, 23:10 En Xiaomi Mi Box (todas las versiones)
0 Respuestas
994 Vistas
por frankncorral
15 May 2018, 23:10