Por lcsagredo
Novato
Autor del hilo
#96733
Hola, soy nuevo en este foro, y también en este mundo, así que perdonad si suelto alguna obviedad.
Tengo dos RPI 4 con 2M de memoria compradas con un mes de diferencia, con la idea de tener acceso a la TDT en dos televisores "tontos" sin acceso a una toma de antena, y de paso convertirlos en "smart TV" a un precio razonable. Para ello uso un decodificador que conecto a la toma de antena y que distribuye la señal en streaming en la LAN. La grabación y el eventual timeshift se hace en el disco local del decodificador. No tengo ninguna intención de abrir puertos y acceder desde Internet.
La primera RPI la compré para probar toda la configuración. Instalé libreelec 9.2.5 en una Sandisk de 16G, que era la última versión estable en ese momento, y lo configuré todo, incluyendo varios addons de kodi, todos ellos de la distribución incluida con libreelec excepto Amazon VOD, que cogí de Github, que me pareció lo más seguro. Todo quedó funcionando a mi satisfacción y lo tuve funcionando una semana en pruebas sin ningún problema. Me decidí pues a comprar la segunda RPI 4 donde repliqué la configuración excepto que la SD era de 8G, también Sandisk.
En esta segunda RPI comenzó a aparecer el problema. Cada pocas horas, aunque sin periodicidad definida, el interfaz de kodi se congelaba sin recuperación posible. El SO estaba vivo. Podía acceder vía samba y ssh sin problemas. Mi impresión es que kodi también estaba vivo, pero no se me ocurrió cómo comprobarlo. Lo más sorprente, al menos para mí, es que tras un reboot exitoso ( comprobado en ssh) la pantalla seguía congelada con la misma imagen. La única solución era quitar la alimentación.
Tras revisar en San Google, decidí configurar el tamaño de la caché a un 90% de 1/3 de la memoria libre - 380M. Además, actualicé a libreelec 9.2.6. Hice lo mismo en las dos RPI 4.
Con ello he aumentado el tiempo de funcionamiento sin fallos, pero hoy ha vuelto a aparecer tras varios días en pruebas. Además también ha aparecido en la primera RPI, por lo que he cancelado la siguiente prueba, intercambiar las SD, al fallar las dos.
El fallo puede aparecer durante la reproducción, pero también mientras se cambia de menú sin estar reproduciendo nada.
La LAN no es un cañón, pero funciona razonablemente. Además, yo entendería que la reproducción andara a tirones al conectar el segundo cliente de streaming, pero no que se congelé sin recuperación posible.
No he encontrado nada parecido en San Google salvo referencias al tamaño de la caché, y se me ocurren un par de pruebas adicionales, pero mientras tanto, ¿a alguien se le ocurre algo?.
Muchísimas gracias por anticipado.
Creo que ahora el hilo es correcto

Por -ice-
Maestro
#96736
Pero, ¿Has llegado a cambiar la microSD?

Yo hago +/- lo mismo que tú sólo que, en mi caso en lugar de TDT son los canales satelitales. Sería lo mismo para la TDT, pero mi deco es twin sat.
Y lo hago en casa con un tv, el proyector, mi hija desde BCN y un amiguete desde Alicante.
Uso unos Fire Stick 4K y un Lite con E2streamer cómo app. El deco es un Octagon SF8008.
Sólo se entrecorta (en SD, supongo que en HD sería antes) en los clientes cuándo hay al menos tres solicitando el stream.

Temas similares
Temas Estadísticas Último mensaje
Problemas de imagen
por Romesa74  - 27 Oct 2020, 20:25 En Kodi
0 Respuestas
90 Vistas
por Romesa74
27 Oct 2020, 20:25
Kodi no sincroniza imagen y sonido
por Juanjo Barcelona  - 21 Ene 2020, 21:45 En Smart TV
4 Respuestas
1909 Vistas
por Xvier76
02 Mar 2020, 17:21
Kodi no sincroniza imagen y sonido
por Juanjo Barcelona  - 20 Ene 2020, 11:56 En Kodi
0 Respuestas
701 Vistas
por Juanjo Barcelona
20 Ene 2020, 11:56
LibreElec no se ve a traves del AVR
por humberthx  - 18 Feb 2020, 23:28 En LibreELEC
1 Respuestas
1265 Vistas
por humberthx
28 Mar 2020, 21:50
libreelec puertos
por anchoita  - 31 Ene 2020, 17:25 En LibreELEC
0 Respuestas
777 Vistas
por anchoita
31 Ene 2020, 17:25