Por cherrerap
Novato
Autor del hilo
#95381
Estimados,

Tengo instalado mariadb utilizando Docker en mi servidor LibreElec (intel) que ejecuta Krypton que ademas es un servidor de archivos en el cual tengo peliculas y series, a este equipo lo llamare "servidor"... es una PC con libreelec y un disco duro local de varios teras..

Ademas, tengo otro equipo .. un raspberry igual con libreelec (misma versión).. ambos funcionan de maravilla compartiendo la libreria por SMB y sincronizando el catalogo con mariadb.. funciona bien salvo por un detalle:

Antes, cuando no tenia mariadb y las bases de datos eran solo locales (independientes) mi "servidor" encendia libreelec con o sin conexion a Internet, pero ahora unicamente enciende cuando mi router esta encendido.. Si no lo está, luego del logo de LibreElec se queda intentando cargar la interface grafica y nunca termina.. unicamente cuando enciendo el router y se activa internet termina de "iniciarse"..

No es un problema de la red, ya que el equipo (servidor) esta conectado a un switch independiente del router, por lo que su puerto LAN identifica que si hay red.. lo que no tiene es internet..

Por las noches tengo la costumbre de apagar el router, pero deberia poder seguir utilizando KODI sin problemas.. (Asi era antes).. ahora dependo que el router este encendido..

Le ha pasado a alguno de ustedes este problema?


De antemano, muchas gracias por sus comentarios

Avatar de Usuario
Por roliverosc
Maestro
#95388
Esto es así porque Kodi no encuentra la base de datos que tiene que cargar al estar esta en otro equipo. Es una de las pegas de NO tener la bd en local, el equipo con mariadb debe de estar permanente conectado o al menos estarlo cuando algún equipo que debe leerla la necesita. Al tener el router apagado no existe una lan donde buscar y conectar. Es tan simple como eso.

Enviado desde mi Redmi Note 7 mediante Tapatalk

Por cherrerap
Novato
Autor del hilo
#95404
Gracias @roliverosc por tu interes en mi problema.. Desafortunadamente no es mi caso, no me dejé entender bien en mi mensaje.. me explico:

Tengo 2 libreelec, uno en una PC Intel (1) y otro en un raspberry (2). El libreelec de la PC lo utilizo (ademas de media player) como servidor de archivos con SMB, comparto la libreria con MariaDB (docker) y tambien los Thumbnails (por SMB)... Tengo claro que si el 1 no esta encendido, el raspberry (2) no va a poder mostrar la libreria y menos reproducir los videos.. aunque realmente si enciende cuando el (1) no esta encencido, pero es claro que no muestra la libreria... en conclusión no se puede operar.

El problema real lo tengo con el servidor (1). Si este no esta conectado a internet no termina de encender, lo cual es muy extraño ya que la BD de MariaDB se ejecuta ahi mismo, por lo que no deberia existir un problema de dependencia... se queda intentando encender.. es decir.. se muestra el logo de LibreElec, pero se queda con el puntero del mouse (que SI se puede mover) pero no llega a cargar el logo de "KODI"... puede quedarse así por varios minutos, solo tengo que encender el router y listo.. funciona... Si luego de encendido, apago el router.. libreelec continua funcionando sin ningun problema.. el error unicamente ocurre al intentar encender.. es bastante extraño.

Pregunto : A los usuarios que utilizan Libreelec + MariaDB en Docker + SMB.. les ocurre lo mismo ? Se depende de Internet para "algo" ?? He intentado cambiar el skin, pero nada.. no es un problema de RED porque la interface ethernet si esta operativa, lo que no tiene obviamente es llegada al servidor DNS ni al gateway (el router)..

Por ahora, debo tener presente que para encender LibreElec (1) el router debe estar encendido tambien...

Gracias de antemano por cualquier orientacion..
roliverosc le gusta esto

Temas similares
Temas Estadísticas Último mensaje
LibreElec + Docker + PMS (Plex)
por cherrerap  - 16 Sep 2019, 17:06 En LibreELEC
1 Respuestas
821 Vistas
por cherrerap
19 Sep 2019, 19:04
libreelec solo arranca desde android apk reboot to libreelec
por grema90  - 04 Mar 2019, 12:34 En LibreELEC
2 Respuestas
1196 Vistas
por grema90
04 Mar 2019, 18:07
Problema al conectar con mi red de internet
por JCHacking  - 31 Ago 2019, 00:18 En Linux
0 Respuestas
530 Vistas
por JCHacking
31 Ago 2019, 00:18
Krypton 17.6
por carpeam  - 27 Abr 2019, 20:58 En Kodi
0 Respuestas
424 Vistas
por carpeam
27 Abr 2019, 20:58