• 1
  • 35
  • 36
  • 37
  • 38
  • 39
Avatar de Usuario
Por manuelin
Moderador
Autor del hilo
#94574
papadopoul escribió:Hola, tengo un problema al instalar el grabber. Me da error en la instalación. Si abro el log aparece:
GNU nano 2.9.3 Tvheadend_Movistar-Spain.log

chown: usuario inválido: «UNKNOWN:UNKNOWN»
chown: usuario inválido: «UNKNOWN:video»
chown: usuario inválido: «UNKNOWN:UNKNOWN»
chown: usuario inválido: «UNKNOWN:video»


Probablemente la he liado al cambian el usuario en /etc/passed del usuario original al root como:

hts:x:0:0::/home/hts:/bin/bash


Como puedo solucionar el problema de permisos? Es decir que carpetas debería de modificar los permisos? O como podría volver al usuario por defecto sin reinstalar todo?

Gracias!

Te da error al aplicar los permisos, no es capaz de detectar/encontrar que usuario poner a los ficheros de configuración o bien el usuario que está intentando poner no existe.

Sea cual sea no sé muy bien que decirte, osea no tengo ni idea de que usuario se supone que tienes y menos aún si dices que te has puesto a cambiar y renombrar usuarios.


sudokun escribió:
sudokun escribió:Es posible enque en el apartado Canales/epg no me aparezcan ni me deje añadir ninguno?
salu2


Me pasa desde qyuue he lanzado el scrip para actualizar la lista.Como al aplicarlo perdemos la lista del tdt, me he dado cuenta de eso no aparecen los canales en ese apartado y lo mas curioso es que no me deja añadir ninguno.
Puede ser cuestion de permisos en anguna carpeta si es asi en cuala alguien me alumbra
gracias

Debe de ser tema de permisos, que no tiene permisos para modificar los archivos de configuración y por eso no se queda guardado, supongo.

¿Qué sistema operativo tienes? ¿Sabes qué usuario/grupo se supone que debería de tener el Tvheadend en tu instalación?


wooming100 escribió:Una duda tengo un kii pro con libreelec y cuando cargo esto por puttty al entrar en tvheaded no me sale sintonizador por qué puede ser?

Enviado desde mi Redmi Note 7 mediante Tapatalk

¿Te refieres a que no te aparece el sintonizador de satélite en el apartado de adaptadores?
¿Pero antes de pasar el script te aparecía? ¿O no llegaste a mirarlo?

Lo digo porque sería rarísimo ya que el script no toca nada respecto al tema de los adaptadores, e incluso aunque lo tocase sería solamente tema de configuración en el Tvheadend, osea no podría llegar a hacerlo desaparecer ya que eso es hardware y el Tvheadend lo detecta y reconoce del propio sistema, no de la configuración del programa. No sé si me explico.


chitenavi escribió:Hola a todos, bueno quisiera preguntar si este script valdría para tvheadend en versión docker??. Tengo una placa rock64, como NAS con openmediavault 4 y aproveche docker para instalar tvheadend y oscam, junto con un digibit r1 ya lo tengo funcionando.
Ahora estoy con el tema de los canales y el epg, veo que esto simplifica las cosas bastante y surge si funcionaría, no he probado. Gracias

Enviado desde mi MI 5s Plus mediante Tapatalk

Debería de valer, supongo que usando la opción de 'Linux', aunque no sé que rutas ni usuarios ni grupos ni nada usará dicho contenedor de Docker... Como esos contenedores cada uno los hace de una manera. Así que depende como esté organizado por dentro dicho contenedor de Docker funcionará bien o no, sin probarlo a saber y más aún cuando cada contenedor es un mundo.

Un saludo ;)

Por pepealvarez
Novato
#94589
Holaa
Hace un par de dias al intentar detener la tarea de TVHEADEND le di sin querer a desinstalar, pero volvi a instalar la misma version y aparentemente me recupero toda la configuracion... Sin embargo no me sale en los modulos para capturar Egp, el graber "interno xmlt movistar+ "

y al intentar instalarlo de nuevo siempre me da error en la descarga, intentelo de nuevo mas tarde
**********************
[email protected]:/usr/local/bin# sudo ./Tvheadend_Movistar-Spain.sh -g
./Tvheadend_Movistar-Spain.sh: line 47: [: 20191004: unary operator expected
Se ha detectado el sistema operativo Synology/XPEnology. ¿Es correcto? [S/n] s
Se ha detectado una versión de la lista de canales previamente instalada.
- Lista de canales:
Versión instalada: 20191008 Última versión disponible:
./Tvheadend_Movistar-Spain.sh: line 292: [: 20191008: unary operator expected
Su lista de canales ya está actualizada y por tanto no hace falta que se vuelva a instalar.
¿Desea reinstalar la lista de canales? [S/n] n
Se ha detectado una versión del grabber de Movistar+ previamente instalada.
- Grabber (EPG de canales):
Versión instalada: 20191004 Última versión disponible:
./Tvheadend_Movistar-Spain.sh: line 315: [: 20191004: unary operator expected
Su grabber ya está actualizada y por tanto no hace falta que se vuelva a instalar.
¿Desea reinstalar el grabber? [S/n] s
* Deteniendo Tvheadend [ OK ]
* Descargando grabber de Movistar+ [FAILED]

El grabber de Movistar+ no se ha podido descargar.
Por favor, vuelva a intentarlo más tarde.

**********************
¿Alguna sugerencia? ... ¿desinstalo de nuevo TVHEADEND y vuelvo a instalarlo de nuevo?...

Un millon de gracias por vuestra ayuda
saludos

Por trick5
Novato
#94612
Buenas a todos!

A ver si alguien me da luz sobre un problema que estoy teniendo desde que actualicé el script (Tvheadend_Movistar-Spain.sh) a la última versión...

Lo ejecuta sin ningún problema con todos los OK debidos. El problema es que en el cliente del TVH (kodi, TVHclient...) no me carga la EPG. He comprobado que al ejecutar el grabber directamente del local/bin carga todo el contenido bien, por lo que tiene que ser algún problema de permisos o vinculación con los canales?? A alguien más le pasa??

Muchas gracias, en especial a @manuelin por compartir su pedazo de programa! ;)

Saludos!

Por cornholio
Novato
#94613
trick5 escribió:Buenas a todos!

A ver si alguien me da luz sobre un problema que estoy teniendo desde que actualicé el script (Tvheadend_Movistar-Spain.sh) a la última versión...

Lo ejecuta sin ningún problema con todos los OK debidos. El problema es que en el cliente del TVH (kodi, TVHclient...) no me carga la EPG. He comprobado que al ejecutar el grabber directamente del local/bin carga todo el contenido bien, por lo que tiene que ser algún problema de permisos o vinculación con los canales?? A alguien más le pasa??

Muchas gracias, en especial a @manuelin por compartir su pedazo de programa! ;)

Saludos!


Buenas.
No es problema tuyo. No te carga la EPG porque la EPG que está descargando no está actualizada. Lo último que aparece es de ayer.
He mirado en github el xml que se descarga y efectivamente no está actualizado. Justo hoy se me ha quedado todo en blanco.

Un saludo.

Por Siderfa
Novato
#94615
SI, creo que estamos muchos así, ahora mismo sin EPG.

Por trick5
Novato
#94616
Muchas gracias compi! Me ha coincidido que lo actualicé justo hace unos días y pensé que era eso. Me quedo más tranquilo. A ver si recarga solo o necesitamos tocar el script.

Un saludo!

cornholio escribió:
trick5 escribió:Buenas a todos!

A ver si alguien me da luz sobre un problema que estoy teniendo desde que actualicé el script (Tvheadend_Movistar-Spain.sh) a la última versión...

Lo ejecuta sin ningún problema con todos los OK debidos. El problema es que en el cliente del TVH (kodi, TVHclient...) no me carga la EPG. He comprobado que al ejecutar el grabber directamente del local/bin carga todo el contenido bien, por lo que tiene que ser algún problema de permisos o vinculación con los canales?? A alguien más le pasa??

Muchas gracias, en especial a @manuelin por compartir su pedazo de programa! ;)

Saludos!


Buenas.
No es problema tuyo. No te carga la EPG porque la EPG que está descargando no está actualizada. Lo último que aparece es de ayer.
He mirado en github el xml que se descarga y efectivamente no está actualizado. Justo hoy se me ha quedado todo en blanco.

Un saludo.

Avatar de Usuario
Por manuelin
Moderador
Autor del hilo
#94645
@trick5 @cornholio @Siderfa
Ya debería de estar funcionando de nuevo la EPG, gracias a @Tocinillo.

Si seguís sin EPG es porque todavía no ha llegado la hora a la que tengáis programado el Tvheadend que vuelva a ejecutar el grabber.

Así que si seguís sin EPG probad primero a forzar manualmente la ejecución del grabber:
Tvheadend > Configuración > Canales / EPG > Capturador de EPG > Volver a ejecutar los capturadores de EPG internos.

Un saludo ;)

Avatar de Usuario
Por manuelin
Moderador
Autor del hilo
#94646
pepealvarez escribió:Holaa
Hace un par de dias al intentar detener la tarea de TVHEADEND le di sin querer a desinstalar, pero volvi a instalar la misma version y aparentemente me recupero toda la configuracion... Sin embargo no me sale en los modulos para capturar Egp, el graber "interno xmlt movistar+ "

y al intentar instalarlo de nuevo siempre me da error en la descarga, intentelo de nuevo mas tarde
**********************
[email protected]:/usr/local/bin# sudo ./Tvheadend_Movistar-Spain.sh -g
./Tvheadend_Movistar-Spain.sh: line 47: [: 20191004: unary operator expected
Se ha detectado el sistema operativo Synology/XPEnology. ¿Es correcto? [S/n] s
Se ha detectado una versión de la lista de canales previamente instalada.
- Lista de canales:
Versión instalada: 20191008 Última versión disponible:
./Tvheadend_Movistar-Spain.sh: line 292: [: 20191008: unary operator expected
Su lista de canales ya está actualizada y por tanto no hace falta que se vuelva a instalar.
¿Desea reinstalar la lista de canales? [S/n] n
Se ha detectado una versión del grabber de Movistar+ previamente instalada.
- Grabber (EPG de canales):
Versión instalada: 20191004 Última versión disponible:
./Tvheadend_Movistar-Spain.sh: line 315: [: 20191004: unary operator expected
Su grabber ya está actualizada y por tanto no hace falta que se vuelva a instalar.
¿Desea reinstalar el grabber? [S/n] s
* Deteniendo Tvheadend [ OK ]
* Descargando grabber de Movistar+ [FAILED]

El grabber de Movistar+ no se ha podido descargar.
Por favor, vuelva a intentarlo más tarde.

**********************
¿Alguna sugerencia? ... ¿desinstalo de nuevo TVHEADEND y vuelvo a instalarlo de nuevo?...

Un millon de gracias por vuestra ayuda
saludos


@pepealvarez creo que te está fallando cada vez que intenta consultar un fichero del repositorio de GitHub.

Por ejemplo, te falla siempre que intenta leer los números de las versiones del script, lista de canales y grabber, de este fichero de GitHub:
https://github.com/manuelrn/Tvheadend_M ... ersion.txt

Vamos que no es capaz de acceder al fichero de esa URL.

Comprueba por si acaso que en la máquina donde estés ejecutando el script tiene acceso a Internet, y también que es capaz de acceder a dicha URL y ver su contenido.

Un saludo ;)

Por pepealvarez
Novato
#94651
Holaaa @manuelin
un millon de gracias, el NAS si salia a internet, pero de repente me he acordado de lo que @Tocinillo lleva días comentando del bloqueo del acceso a GitHub, por las operadoras telefonicas y le he cambiado las DNS al Nas por las de Google, en lugar de las que me asigna automaticamente Orange y en un plis plas lo ha hecho todo. Ya tengo de nuevo el Grabber activado

Gracias de nuevo
Un saludo
Pepe
manuelin le gusta esto

Por kong357
Novato
#94830
Buenas,

en primer lugar, gracias por el grandísimo trabajo :grinning: La lista de canales, la EPG, el script...genial :heart_eyes:

El caso es que en versiones 4.3.xx (no sé como irá en versiones anteriores) existe la opción, en las reglas de Autorec, de grabar/filtrar por temporadas (grabar una temporada concreta, a partir de una temporada, hasta cierta temporada, rango de temporadas, etc.) pero esto sólo funciona si existe el campo "<episode-num system="xmltv_ns">4.12.0/0</episode-num>" (que vendría a decir "temporada 5, episodio 13, parte 1 de 1". Hay que sumar 1 a esos números para obtener temporada, capítulo y parte del capítulo en caso de haber varias partes).
Sí existe el campo "<episode-num system="onscreen">S5 E13</episode-num>" pero aparentemente sólo sirve para mostrar "S5 E13" en el campo "Episodio" de la EPG. No vale para las reglas de autorec y tampoco envía temporada y episodio a kodi por lo que tendremos que esperar que estos datos aparezcan en el título o descripción para saber qué capítulo y de qué temporada es lo que estamos viendo.

No sé si sería posible añadir este campo al recabar los datos de la EPG antes de montar el archivo xml. Lo que sí he conseguido hacer es añadirlo una vez creado el "guiatv.xml".
Para ello es necesario añadir la siguiente línea: "perl -p -e 'if(/(<episode-num system=)"onscreen">S(\d+) E(\d+)/) {my $s=$2-1; my $e=$3-1; print qq!$1"xmltv_ns"> $s . $e . 0/0</episode-num>\n!}'" sin comillas por lo que el "tv_grab_movistar-spain" quedaría de la siguiente manera:
Código: Seleccionar todo...
if [ "$xmltv_type" = "FILE" ]
   then
      if [ "${xmltv_file_location##*.}" = "gz" ]
      then
         zcat "$xmltv_file_location" | perl -p -e 'if(/(<episode-num system=)"onscreen">S(\d+) E(\d+)/) {my $s=$2-1; my $e=$3-1; print qq!$1"xmltv_ns"> $s . $e . 0/0</episode-num>\n!}'
         exit 0
      else
         cat "$xmltv_file_location" | perl -p -e 'if(/(<episode-num system=)"onscreen">S(\d+) E(\d+)/) {my $s=$2-1; my $e=$3-1; print qq!$1"xmltv_ns"> $s . $e . 0/0</episode-num>\n!}'
         exit 0
      fi
   elif [ "$xmltv_type" = "URL" ]
   then
      if [ "${xmltv_url_location##*.}" = "gz" ]
      then
         wget -qO - "$xmltv_url_location" | zcat | perl -p -e 'if(/(<episode-num system=)"onscreen">S(\d+) E(\d+)/) {my $s=$2-1; my $e=$3-1; print qq!$1"xmltv_ns"> $s . $e . 0/0</episode-num>\n!}'
         exit 0
      else
         wget -qO - "$xmltv_url_location" | perl -p -e 'if(/(<episode-num system=)"onscreen">S(\d+) E(\d+)/) {my $s=$2-1; my $e=$3-1; print qq!$1"xmltv_ns"> $s . $e . 0/0</episode-num>\n!}'
         exit 0
      fi
   fi
...


Lo que hace es añadir el "episode-num system="xmltv_ns"" a la vez que mantiene el "episode-num system="onscreen"" basándose en éste último para sacar la temporada y número de capítulo. Cuando no existe "episode-num system="onscreen"" no añade nada ya que no hay de dónde sacar xD También, al añadir esto, tvh envía la temporada y capítulo a kodi por lo que no habría que esperar que esta info estuviese en el título/descripción.

Cabe mencionar que mis conocimientos de programación son escasos o nulos pero con un poco de aquí y de allí y a base de prueba y error he conseguido hacer que funcione (al menos en mi instalación). Si alguien sabe de alguna manera mejor de hacerlo... ;)

Parece que existe un pequeño bug en tvh (ya reportado https://tvheadend.org/issues/5800) que hace que aquellos eventos que no tengan ningún "episode-num", ni "onscreen" ni "xmltv_ns" ni nada en el xml, serán grabados aunque filtres por temporada (los que sí tengan el campo sí serán filtrados y, por lo tanto, NO serán grabados o sí, depende de lo que queráis xD) pero bueno, al menos la modificación funciona y sólo queda esperar que solucionen el bug.

Espero que os sirva y si vale para mejorar el script de @manuelin , mejor que mejor :grin:

PD.: Obviamente habrá que tener instalado perl si es que aún no lo tenéis.
Adjuntos
Captura_Autorec-La_que_se_avecina1.jpg
Captura_Autorec-La_que_se_avecina1.jpg (97.25 KiB) Visto 1277 veces

Por kong357
Novato
#94831
Os dejo un ejemplo de lo que ocurre cuando no existiendo el campo "episode-num" y creando una regla de autorec para que grabe por ejemplo la temporada 5 de "La que se avecina".
En la captura, además de aparecer el único capítulo de la temporada 5 que está en la guía, también aparecen capítulos sin temporada ni número de episodio en la pestaña de "Grabaciones en curso/próximas".
Adjuntos
Captura_grabaciones-La_que_se_avecina.jpg
Captura_grabaciones-La_que_se_avecina.jpg (199.39 KiB) Visto 1276 veces
Descard3 le gusta esto

Por kevy
Colaborador
#94834
Descard3 escribió:Como instalas TVH 4.3.xx?


Yo estoy en las mismas, como lo instalas imagino que manualmente no?

Salu2.

Por kong357
Novato
#94837
Sí, compilando pero en arch, que es la que uso, y derivadas basta con "yay tvheadend-git" o "yay tvheadend" si prefieres la 4.2.8.

Para debian/ubuntu y derivadas https://tvheadend.org/projects/tvheaden ... positories

Fedora y similares https://tvheadend.org/projects/tvheaden ... Repository

Si aparecen errores al compilar supongo que serán por dependencias no satisfechas.

Os recuerdo que la 4.3, así como todas las versiones con el último número impar, son de desarrollo, "unstable" (4.1, 4.3, 4.5...). Las que terminan con número par son las estables.
Descard3 le gusta esto

  • 1
  • 35
  • 36
  • 37
  • 38
  • 39
Temas similares
Temas Estadísticas Último mensaje
Tvheadend, cortes continuos en canales HD(Satelite).
por javichu68  - 18 Feb 2020, 14:04 En PVR
3 Respuestas
1929 Vistas
por Javichun
20 Feb 2020, 22:42
X96 adons lista canales
por Cambolio  - 04 Sep 2019, 14:15 En LibreELEC
1 Respuestas
2420 Vistas
por Yorick
04 Sep 2019, 23:08
Lista de canales personalizada
por webchedra  - 22 May 2020, 11:39 En Windows
0 Respuestas
866 Vistas
por webchedra
22 May 2020, 11:39
Actualizar lista de canales KODI
por Raul Aldea  - 18 Ene 2020, 12:01 En Kodi
0 Respuestas
1230 Vistas
por Raul Aldea
18 Ene 2020, 12:01
El rey león (2019)
por speedmoska  - 24 Ene 2020, 20:08 En Movie Fanart (Películas)
0 Respuestas
730 Vistas
por speedmoska
24 Ene 2020, 20:08