Por humberthx
Novato
Autor del hilo
#96128
Buenas a todos,

recurro a vosotros después de buscar por todos los lados.

Os cuento. Tengo una RPI4 funcionando con Libreelec y reproduciendo contenido a 4K x265 HEVC sin problemas.

Por otro lado tengo montado un ambilight casero con Hyperion + Arduino y también está funcionando perfectamente hasta que reproduzco contenido en el codec anterior.

En cuanto le pongo a reproducir contenido con ese codec las luces se ven en color verde. No se quedan fijas en ese color, sino que les varía la intensidad, pero siempre en el mismo color verde y siempre con ese codec.

He leido por ahi que lanzando el siguiente comando se arreglaba:
Código: Seleccionar todoecho 1 | tee /sys/module/amvdec_h265/parameters/double_write_mode

pero en libreelec esto no funciona. No existe dicha ruta. Tampoco se que han puesto para que se cree dicha ruta.

Alguien le pasa lo mismo y tiene la solución??

Saludos y gracias de antemano.

Por -ice-
Maestro
#96129
¿Usas Arduino por el tipo de led?
Yo estoy desconectado del tema Hyperion porque desmonté la RPi4 pero la última vez que la utilicé (Hyperion y led WS2801 creo recordar) no me había dado ningún problema.
Hay un hilo muy activo en EOL sobre Ambilight casero con un participante, el compañero @popy5, que sabe y controla muchísimo del tema.

Por humberthx
Novato
Autor del hilo
#96130
Hola ICE,

sí, efectivamente uso el arduino porque el tipo de LED que uso no lo puedo conectar directamente a los puertos GPIO de la RPI o al menos yo no he sabido hacerlo.

Los tenía montados anteriormente con el Boblight en KODI sobre un PC. Tenían cierta latencia aunque funcionaba bien. No tenía x265 en aquella época. Pero al pasar a la RPI me di cuenta que los que se conectan al GPIO eran otros LED.

Los mios son los WS2812 (solo 3 cables) y el arduino simula un Adalight. Con el Hypercon lo tengo que configurar así, como Adalight.

Le echaré un ojo a ese hilo que me has dicho.

Muchas gracias!!

Temas similares
Temas Estadísticas Último mensaje
CODEC X265 EN RASPBERRY?
por NicholasJaxson  - 12 Sep 2020, 11:17 En Raspberry Pi
1 Respuestas
86 Vistas
por -ice-
12 Sep 2020, 23:00
Mundocine error de registro
por Olkebi  - 20 Oct 2019, 18:20 En Add-ons Kodi
0 Respuestas
2618 Vistas
por Olkebi
20 Oct 2019, 18:20
Error al exportar libreria
por krlsant  - 27 Dic 2019, 20:20 En Kodi
0 Respuestas
737 Vistas
por krlsant
27 Dic 2019, 20:20
Error plexus y acestream
por Chimutrek  - 04 Mar 2020, 11:28 En Nvidia Shield TV
0 Respuestas
1775 Vistas
por Chimutrek
04 Mar 2020, 11:28
Sobre error gdrive
por Agustina  - 21 Ago 2020, 16:48 En Raspberry Pi
1 Respuestas
2793 Vistas
por veneno60
23 Ago 2020, 09:14