• 1
  • 56
  • 57
  • 58
  • 59
  • 60
Por cana
Donante
#95653
Buenas tardes, he procedido a actualizar mi NAS pasando del DSM 5.2 AL 6.2. Ha habido distintos obstáculos que hizo solventando por el camino, gracias a los distintos comentarios y lo tengo ya unos días funcionando.

Pero tengo un problema y no encuentro la solución. Desde que realicé la actualización, más o menos cada 24 horas, el NAS pierde la conexión y desaparece de la red. No puedo tener acceso a él desde la consola DSM del PC, no puedo acceder a las carpetas a través de la red interna y ni siquiera puedo apagarlo desde la consola, teniendo que proceder a reiniciarlo a capón desde el botón del NAS.

Sabéis a que se puede deber y como puedo solucionarlo?

Muchas gracias! Un saludo!

Por ksero
Novato
#95659
Hola,
qué versión has puesto? 6.2.2? ó 6.2.1?
Que placa montas?
Si es la última, 6.2.2 te aconsejo que bajes a la 6.2.1.

Saludos

Por cana
Donante
#95660
ksero escribió:Hola,
qué versión has puesto? 6.2.2? ó 6.2.1?
Que placa montas?
Si es la última, 6.2.2 te aconsejo que bajes a la 6.2.1.

Saludos


Hola, muchas gracias por la respuesta y la ayuda. La versión de DSM es la 6.2-23739, que leí que era la que funcionaba. Me dice que está disponible la 6.2.2-24922 pero no he pasado a esa porque era la que supuestamente no funcionaba bien.

La placa es una Asrock Q1900-ITX.

Un saludo!

Por pleite
Novato
#95818
Nada, llevo tres días intentando y no hay manera
Antes de tocar mi Server xpenology DSM 6.1.7 instalado en una j4205 por si las moscas y me lo cargo he probado a hacerlo en un pc con placa gigabit y un Athlon 64x2 con un HD formateado.
Sigo los pasos del manual al pie de la letra, bootloader 1.04b, modifico el synoboot-ds918 con el pid y vid, probado modificando el SATAPORTMAP en 4 y 22, se queda en la pantalla de find.synology.com, no carga el kernel como en la versión 1.02b y no aparece en la red local y evidentemente el assistant no lo encuentra.
Con el bootloader 1.02b lo encuentra perfectamente, con el 1.03b tampoco lo encuentra.
La tarjeta de red es Realtek.
Alguien sabría donde puede estar el problema?

Por yosolo
Novato
#95820
Pues la tarjeta de red o el procesador, o ambas cosas

Avatar de Usuario
Por iparras
Experto
#95821
Normalmente por la tarjeta de red, las últimas versiones solo admite algunas Intel. Mira bien el hard compatible.

Enviado desde mi SM-G965F mediante Tapatalk

Por ksero
Novato
#95823
Han sacado un paquete nuevo 1.03B compatible con la versión 6.2.3. Prueba a ver si te va

Por pleite
Novato
#95831
Imagino sera por la tarjeta de red
Con el 1.04b no tiene red
Con el 1.03b tiene red pero no encuentra el disco duro
Con el 1.02b perfecto 6.1.7 y me pide actualizar a la 6.2.2-24922 que evidentemente si actualizo se jode el tinglao

Por prekopix
Iniciado
#95833
Leyendo por aquí y por allá, que también quiero subir de 6.1.7 a 6.2, veo que lo mas practico seria borrar la primera partición de todos los discos, ya que parece que el sistema se instala en esa partición y en todos y cada uno de los discos, y después instalar el nuevo DSM y así te pillaría automáticamente el raid. Seria esto correcto?

Por BAD1959
Novato
#95842
Hola, quiero contaros algo que me ha pasado, por si es de ayuda para alguién.
Tengo un Gen8 desde hace 3 años, le instalé Xpenology y funcionando sin problemas hasta hace unos cuantos meses o un año, no recuerdo bien.
El caso es que me salía un mensaje cuando queria actualizar dicíendome que no tenia espacio suficiente en la memoria para poder hacerlo.
Como todo me funcionaba bien pues lo dejé correr durante todo éste tiempo, pero el otro dia me picó el gusanillo de arreglarlo.
Lo primero que hice fué pillar una tarjeta de red INTEL, porque ya sabía que si no no podia pasar de version de DSM.
Investigando por diversos foros conseguí saber cual era el problema de
la actualización, parece ser que de alguna forma me creó un archivo en la raiz de la memoria que se llama .SynoUpdate.tar que ocupaba la cantidad de más de 700 Mb, pues bien siguiendo las indicaciones que encontré conseguí borrarlo de la memoria, problema resuelto, le di a actualizar y ya me indicaba que podia actualizar a la versión de DSM 6.2.2-24922 Update 6, crucé los dedos y le di a actualizar y perfecto.
No se si os valdrá pero ahí lo dejo por si acaso.
Un saludo.

Por pleite
Novato
#95843
Gracias por el aporte socio, lo cierto es que de vez en cuando hacen alguna cosilla rara, yo sigo con 6.1.7 y a mí me ha ocurrido que samba se ha vuelto lentísimo y tira mucho de cpu de un tiempo a ahora, lo raro es que solo pasa con un pc casualmente el que más utilizo.
He hecho mis pruebas y no se que puede ser, accedo al Expenology por samba con otro pc y todo bien y uso de cpu normal, Accedo a otro expenology de pruebas por samba con el pc de marras todo bien y uso de cpu normal.
La red y cableado es el mismo en todos los casos, no sé qué podrá ser pero cuando accedo a dicho expenology con dicho pc samba se pone lento y el uso de cpu es muy alto, en cuanto desabilito samba baja el consumo de cpu, se ve que un día discutieron ese pc y ese expenology y desde entonces no se llevan, ja ja
Un saludo

Por Arlot
Novato
#95915
BAD1959 escribió:Hola, quiero contaros algo que me ha pasado, por si es de ayuda para alguién.
Tengo un Gen8 desde hace 3 años, le instalé Xpenology y funcionando sin problemas hasta hace unos cuantos meses o un año, no recuerdo bien.
El caso es que me salía un mensaje cuando queria actualizar dicíendome que no tenia espacio suficiente en la memoria para poder hacerlo.
Como todo me funcionaba bien pues lo dejé correr durante todo éste tiempo, pero el otro dia me picó el gusanillo de arreglarlo.
Lo primero que hice fué pillar una tarjeta de red INTEL, porque ya sabía que si no no podia pasar de version de DSM.
Investigando por diversos foros conseguí saber cual era el problema de
la actualización, parece ser que de alguna forma me creó un archivo en la raiz de la memoria que se llama .SynoUpdate.tar que ocupaba la cantidad de más de 700 Mb, pues bien siguiendo las indicaciones que encontré conseguí borrarlo de la memoria, problema resuelto, le di a actualizar y ya me indicaba que podia actualizar a la versión de DSM 6.2.2-24922 Update 6, crucé los dedos y le di a actualizar y perfecto.
No se si os valdrá pero ahí lo dejo por si acaso.
Un saludo.


Buenas noches.

Tengo un problema igual con el tema del espacio.
¿Sabrías indicarme como borrar ese archivo?

Gracias y un saludo!

Por mogoto
Novato
#95948
Como he utilizado como base la gran guía de tocinillo, hago unas ciertas modificaciones para meter la última versión.

[COLOR="SeaGreen"]Guía creada originalmente Tocinillo en Kodimania, modificada con actualizaciones para instalar con placa Asrock j4105 (en la misma indica que permite su reproducción en caso de citar su autor y de donde proviene.[/COLOR]
https://www.kodimania.com/viewtopic.php?t=9256

[COLOR="Red"]Todas las modificaciones están en color rojo.[/COLOR]

[COLOR="seagreen"][SIZE="5"][GUÍA] XPENOLOGY 6.2.3 25426, FÁCIL Y SENCILLO[/SIZE][/COLOR]

Imagen


[COLOR="Red"]Guía actualizada a día de hoy 28/05/2020 por mogoto para la instalación de DSM 6.2.3 25426, probado en una placa Asrock j4105 con 8Gb de RAM (2x4Gb DDR4 SODIMM 2400). Para este equipo aparte de la placa y memoria como es lógico falta una fuente de alimentación, un pendrive para realizar la instalación y un hdd donde instalar...una caja aunque no es imprescincible es recomendable :P [/COLOR]

Tutorial para la instalación de Xpenology. Este tutorial es solo instructivo y no usa archivos originales de Synology, por lo que no viola ninguna ley (además de ser código GPL).

El boot NO es mio, ni ha sido creado o difundido de alguna manera por mi ni por Kodimania, procede del foro de Xpenology. Os bajáis la nueva versión V1.0.4B: https:// mega .nz /#F!Fgk01YoT!7fN9Uxe4lpzZWPLXPMONMA --> Usad el DS918[COLOR="red"]+[/COLOR]. [COLOR="Red"]*Los enlaces de mega forocoches me los quitaba, he tenido que poner un espacio para que permita ponerlos[/COLOR]

Sirve para instalar DSM 6.2.[COLOR="red"]3 25426[/COLOR]

Lo primero que necesitaremos es un pendrive; os aconsejo un Sandisk Fit, que son los más pequeños y no sobresalen absolutamente nada. Nos vamos al PC y lo conectamos.

No es necesario averiguar el VID y el PID si usamos una microSD en lugar de un pendrive

Nos bajamos el programa USBDriveinfo https:// mega .nz /#!EI5zVQ7I!4Yrvk-boVNmMzNsNVWLdGPRei1LVHTWYyVC8tWsdDuA lo abrimos y pulsamos sobre Get USB Flash Info, nos dará el VID y el PID que nos hacen falta para el boot:

Imagen



[COLOR="red"]Los apuntamos que son importantes.

Bajar el DSM de la web de synology la 6.2.3 25426

https://global.download.synology.com/download/DSM/release/6.2.3/25426/DSM_DS918%2B_25426.pat?model=DS918%2B&bays=4&dsm_version=6.2.3&build_number=25426

Montar imagen de la DSM con OSFMount[/COLOR]

Modificas la partición donde se encuentra el siguiente archivo:

Nos vamos a la carpeta grub y dentro de éste veremos un archivo llamado grub.cfg, lo abrimos con un editor como Notepad++:

Imagen



Vale, lo primero que tenemos que ver y cambiar son los valores que veis aquí señalados:

Imagen



Y los cambiamos por los valores que nos había dado antes el programa USB Info; ojo con el 0x de delante, que debe mantenerse:

Imagen



Los valores set sn y mac1 se pueden modificar para que nos habilite el WOL y QC, pero eso incurre en delito contra la propiedad intelectual y aquí no se explicará cómo hacerlo.

Bien, ya casi estamos. Solo nos queda establecer el valor SATAPORTMAP (IMPORTANTE: NO, repito NO hacer nada de esto si tenéis un HP G8, no es necesario). Antes de ponerlo, vamos a explicar como funciona. Éste viene esteblecido de la siguente forma:


SataPortMap=ABCD


Donde A es el número de puertos SATA que tiene la primera controladora del sistema, B es el número de SATA de la segunda controladora y así hasta la letra C y D

Por ejemplo, en mi caso los 4 primeros SATA de la placa son de la controladora Intel, los otros 2 son de una controladora ASMedia (esto en la BIOS os lo indica, o si no en la web de la placa del fabricante) por lo que mi combinación sería SataPortMap=42. Si en lugar de ello tuviera 4 controladoras en la placa base del mismo fabricante y otras 4 en una tarjeta Syba PCI-e, por ejemplo, sería: SataPortMap=44. De igual forma, si solo tenemos 4 puertos SATA de la misma controladora en la placa, quedaría: SataPortMap=4

Este paso es el más importante de todos, ya que si lo ponemos mal o bien el boot no tiene los drivers de vuestra controladora (que pasa mucho) no nos dejará continuar la instalación. Como os decía, en mi caso queda: SataPortMap=42 y se pone después del valor HddHotPlug=0, quedando así:

Imagen


Guardamos los cambios

[COLOR="red"]En mi caso con la placa Asrock J4105 el SataPortMap ya viene configurado como SataPortMap=4 y no he tenido que cambiarlo.

Para DSM 6.2.3 (última vesion), el boot 1.04B funciona directamente, pero no funciona la transcodificación por hardware, para que funcione debes de cambiar los extra.lzma por los de este enlace
https://xpenology.com/forum/topic/28321-driver-extension-jun-104b-for-dsm623-for-918/
Actualmente extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.3 v0.11

Es decir, sin haber cerrado el OSFMount, en una de las particiones del DSM 6.2.3 donde se encuentran estos dos archivos (el OSFMount encuentra 3 particiones, en una de ellas) hay que abrirla y reemplazar los dos archivos por estos.


Os recomiendo una vez hayamos guardado la imagen guardada con OSFMount , probar a abrirla de nuevo para comprobar que las modificaciones se han realizado con éxito.[/COLOR]

En nuestro equipo, conectamos el USB y en la BIOS le indicamos que arranque primero desde ahí. IMPORTANTE: Que NO cargue como UEFI, es decir, que cargue como Legacy, si no en DSM 6.2.[COLOR="Red"]3[/COLOR] no os detectará ninguna red.

Por último solo nos queda volver a nuestro PC, bajarnos el Synology Assistant y darle a Buscar. Nos saldrá nuestro NAS, doble click en él y si todo ha ido bien podremos instalar, dándole a la instalación manual y seleccionando el PAT de nuestro PC que hemos modificado anteriormente. Si nos da error en los discos duros (o un mensaje similar, del estilo "hemos detectado que uno de sus puertos SATA..") puede deberse a dos problemas:

1- Que no hemos establecido correctamente el valor SataPortMap=; lo más probable.

2- A veces ocurre. Simplemente conectaremos nuestro equipo a un monitor/TV y cuando cargue el pendrive seleccionaremos de entre la lista, la opción "Force Install" y volvemos a probar desde Assistant de nuevo.

Ahora nos bajamos el programa Win32DiskImager: https://sourceforge.net/projects/win32diskimager/

Lo abrimos y pulsamos sobre la carpeta azul, nos abrirá el explorador de archivos y [COLOR="red"]elegimos el DSM que hemos modificado antes con OSFMount[/COLOR], elegimos nuestro pendrive (la letra, aseguraos que sea la correcta) y pulsamos en Write:

Imagen



Perfecto, nos habrá creado el pendrive booteable. Éste SIEMPRE tiene que estar conectado al equipo, ya que es el encargado de engañar al sistema haciéndole creer que tenemos un Synology.

[COLOR="red"]Ahora solo toca arrancar desde el pendrive en el PC de la Asrock j4105 y luego desde un PC conectado a la misma red con Synology Assistant (bajarlo desde la web de synology) detectará vuestro PC Asrock j4105, y más adelante ya debéis de seleccionar manualmente la instalación del DSM modificado por vosotros.

Con esto tendremos DSM 6.2.3 25426 totalmente operativo.

*NOTA: Hago incapié en la placa Asrock J4105 para dejar constancia que con esta placa me ha funcionado, seguramente vaya con otro hardware, pero yo no puedo ni comprobarlo ni confirmarlo al menos de momento.[/COLOR]

Por cana
Donante
#95952
Muchas gracias por la información. Mi placa es la Asrock Q1900ITX, así que habrá que esperar a ver si alguien confirma que también va con ella y que método hay que utilizar.
Saludos!

Por yosolo
Novato
#95953
Gracias mogoto, no me atrevía a actualizar a 6.2.3... al final me he decidido, entre tus comentarios y los de xpenology lo he conseguido, aunque no me arrancaba desde el usb... Al final, ha arrancado con reinstall, ha reconstruido el sistema y ya está actualizado a 6.2.3 25426.
Placa base Asus P10S-M WS (chipset C236, dual lan intel en teaming) y un i5 6500.
Saludos.

  • 1
  • 56
  • 57
  • 58
  • 59
  • 60
Temas similares
Temas Estadísticas Último mensaje
¿Es fácil armar una pc gamer?
por clickl  - 01 Ago 2020, 10:52 En La taberna
0 Respuestas
53 Vistas
por clickl
01 Ago 2020, 10:52
Problemas Xpenology y red local
por pleite  - 17 Dic 2019, 19:45 En Xpenology
0 Respuestas
1508 Vistas
por pleite
17 Dic 2019, 19:45
Xpenology agregar más discos duros
por HiFifan  - 01 Oct 2019, 15:44 En Xpenology
2 Respuestas
1160 Vistas
por HiFifan
02 Oct 2019, 17:02