• 1
  • 354
  • 355
  • 356
  • 357
  • 358
  • 396
Por poison3frog
Novato
#86919
@vmjuidiaz

poison3frog escribió:Hola buenas, estoy intentado visualizar en mi tv sony 4k el canal partidazo en 4k tambien desde kodi y se ve en verde y pixelado, en ajustes de kodi sale la resolucion en 1080 en sombreado y no me deja cambiarlo. No se si sera x eso. Como se puede ver?
Espero vuestra respuesta.
Gracias

Por vmjuidiaz
Desarrollador
Autor del hilo
#86924
dr.spock escribió:Buenas noches.

Llevo un rato leyendo todo este hilo (reconozco que un poco en diagonal) y estoy tratando de hacer funcionar Movistar TV en una Rpi 3B con LibreElec.

He descomprimido el servidor independiente para rpi en /storage/.kodi/addons y he creado el siguiente servicio en /storage/.config/system.d:

Código: Seleccionar todo[Unit]
Description=Movistar Server TV
After=network-online.target

[Service]
User=root
Group=root
Type=simple
Restart=always
RestartSec=3
ExecStart=/storage/.kodi/addons/MovistarTV.Server/Kodi_MovistarTV_Server.pvr

[Install]
WantedBy=multi-user.target
Alias=movistatv.service


Me sirve para arrancar el servicio y comprobar que está arrancado, pero por algún motivo al reiniciar el libreelec, el servicio aparece inicialmente como "Dead" y lo tengo que volver a arrancar a mano. Eso también me obliga a deshabilitar y volver a habilitar el addon de cliente, sino ni siquiera conecta.

Después de arrancar el server y antes de reiniciar el cliente:
Código: Seleccionar todoLE-Living:~/.config/system.d # netstat -anp | grep 5000
tcp        0      0 0.0.0.0:5000            0.0.0.0:*               LISTEN      634/Kodi_MovistarTV
tcp        0      0 127.0.0.1:5000          127.0.0.1:52672         ESTABLISHED 634/Kodi_MovistarTV
tcp        0      0 127.0.0.1:52672         127.0.0.1:5000          ESTABLISHED 554/kodi.bin
tcp        0      0 127.0.0.1:5000          127.0.0.1:52676         ESTABLISHED 634/Kodi_MovistarTV
tcp        0      0 127.0.0.1:52676         127.0.0.1:5000          ESTABLISHED 554/kodi.bin


Después de reinciar el cliente:
Código: Seleccionar todoLE-Living:~/.config/system.d # netstat -anp | grep 5000
tcp        0      0 0.0.0.0:5000            0.0.0.0:*               LISTEN      634/Kodi_MovistarTV
tcp        0      0 127.0.0.1:5000          127.0.0.1:52874         TIME_WAIT   -
tcp        0      0 127.0.0.1:52672         127.0.0.1:5000          TIME_WAIT   -
tcp        0      0 127.0.0.1:5000          127.0.0.1:52866         TIME_WAIT   -
tcp        0      0 127.0.0.1:5000          127.0.0.1:52864         ESTABLISHED 634/Kodi_MovistarTV
tcp        0      0 127.0.0.1:5000          127.0.0.1:52872         TIME_WAIT   -
tcp        0      0 127.0.0.1:52864         127.0.0.1:5000          ESTABLISHED 554/kodi.bin
tcp        0      0 127.0.0.1:5000          127.0.0.1:52870         TIME_WAIT   -


En resumen, dos problemas:
- El menos importante: no arranca el servicio al iniciar LibreElec
- El "gordo": El cliente parece conectar con el servidor pero no puedo ver ni los canales, ni el EPG, ni reproducier las grabaciones que muestra.

Todo ello ha sido realizado con las últimas versiones disponibles a la hora de escribir este post.

Saludos!

To creo que es por que te falta el parametro -d con el directorio de datos.
Prueba a ponerle ese parametro y pon un directorio donde pueda grabar datos el servidor.
De todas formas para un librelec que siempre va a ejecutar kodi lo mejor seria directamente instalar el addon servidor en kodi.

Por vmjuidiaz
Desarrollador
Autor del hilo
#86925
poison3frog escribió:@vmjuidiaz

poison3frog escribió:Hola buenas, estoy intentado visualizar en mi tv sony 4k el canal partidazo en 4k tambien desde kodi y se ve en verde y pixelado, en ajustes de kodi sale la resolucion en 1080 en sombreado y no me deja cambiarlo. No se si sera x eso. Como se puede ver?
Espero vuestra respuesta.
Gracias

Pues ni idea la verdad, la conexion es por cable?
No se puede cambiar la resolucion deberia autodetectarla.

Por ManoloK
Experto
#86926
Como vayas por Wi-Fi los canales HD suelen ir flojos

Enviado desde mi HTC U Ultra mediante Tapatalk

Por dr.spock
Novato
#86930
vmjuidiaz escribió:To creo que es por que te falta el parametro -d con el directorio de datos.
Prueba a ponerle ese parametro y pon un directorio donde pueda grabar datos el servidor.
De todas formas para un librelec que siempre va a ejecutar kodi lo mejor seria directamente instalar el addon servidor en kodi.

Ah, pues lo había entendido mal. Desinstalé el addon servidor porque creí que funcionaba mejor el independiente. Supongo que la recomendación entonces era para otros sistemas/distribuciones.
He probado aún así a especificar el directorio y aún así el directorio se mantiene vacío y sigue sin funcionar. Seguiré haciendo pruebas.

Gracias!

Por vmjuidiaz
Desarrollador
Autor del hilo
#86931
dr.spock escribió:
vmjuidiaz escribió:To creo que es por que te falta el parametro -d con el directorio de datos.
Prueba a ponerle ese parametro y pon un directorio donde pueda grabar datos el servidor.
De todas formas para un librelec que siempre va a ejecutar kodi lo mejor seria directamente instalar el addon servidor en kodi.

Ah, pues lo había entendido mal. Desinstalé el addon servidor porque creí que funcionaba mejor el independiente. Supongo que la recomendación entonces era para otros sistemas/distribuciones.
He probado aún así a especificar el directorio y aún así el directorio se mantiene vacío y sigue sin funcionar. Seguiré haciendo pruebas.

Gracias!

Los 2 son iguales salvo los accesos a recursos de disco que uno lo hace a traves de funciones de sistema y el otro a traves de funciones se kodi.

Por dr.spock
Novato
#86932
dr.spock escribió:
vmjuidiaz escribió:To creo que es por que te falta el parametro -d con el directorio de datos.
Prueba a ponerle ese parametro y pon un directorio donde pueda grabar datos el servidor.
De todas formas para un librelec que siempre va a ejecutar kodi lo mejor seria directamente instalar el addon servidor en kodi.

Ah, pues lo había entendido mal. Desinstalé el addon servidor porque creí que funcionaba mejor el independiente. Supongo que la recomendación entonces era para otros sistemas/distribuciones.
He probado aún así a especificar el directorio y aún así el directorio se mantiene vacío y sigue sin funcionar. Seguiré haciendo pruebas.

Gracias!


Burro, burro, burro! :')
Ya he caído en el problema. He detenido el servicio del servidor independiente y he vuelto a instalar el addon servidor... et voilà!.

Ayer, después de haber desinstalado el addon, caí en la cuenta de que tenía filtrado el multicast en el puerto donde tengo conectada la RPi, porque toda la red de mi casa está compuesta por trastos Mikrotik y me saturaba todo el WiFi. Entonces ví que en las nuevas versiones de RouterOS se ha añadido, por fin, el IGMP snooping. Lo activé en todos los dispositivos Mikrotik y fue entonces cuando probé el servidor independiente si que funcionara.

Pero ahora, sin filtros multicast y el IGMP snooping, el addon servidor funciona a la perfección!
Muchas gracias de nuevo por tu ayuda y felicidades por tu trabajo!

Por poison3frog
Novato
#86939
vmjuidiaz escribió:
poison3frog escribió:@vmjuidiaz

poison3frog escribió:Hola buenas, estoy intentado visualizar en mi tv sony 4k el canal partidazo en 4k tambien desde kodi y se ve en verde y pixelado, en ajustes de kodi sale la resolucion en 1080 en sombreado y no me deja cambiarlo. No se si sera x eso. Como se puede ver?
Espero vuestra respuesta.
Gracias

Pues ni idea la verdad, la conexion es por cable?
No se puede cambiar la resolucion deberia autodetectarla.


Buenas, sí, la conexión es por cable, tengo la última versión de kodi, y movistar con tus archivos funciona bien, pero los canales 4k que salen al final de la lista solo se oyen y se ve como comenté en el post anterior, pixelado y verde.

Pienso que si saliera la resolución en 4k en los ajustes de kodi, lo vería sin problemas, pero sale en 1080p y no deja cambiarlo...

Por radioactivetoy
Iniciado
#86940
poison3frog escribió:
vmjuidiaz escribió:
poison3frog escribió:@vmjuidiaz


Pues ni idea la verdad, la conexion es por cable?
No se puede cambiar la resolucion deberia autodetectarla.


Buenas, sí, la conexión es por cable, tengo la última versión de kodi, y movistar con tus archivos funciona bien, pero los canales 4k que salen al final de la lista solo se oyen y se ve como comenté en el post anterior, pixelado y verde.

Pienso que si saliera la resolución en 4k en los ajustes de kodi, lo vería sin problemas, pero sale en 1080p y no deja cambiarlo...
No, yo tengo kodi en 4k con la SHIELD y hace lo mismo. No sé si es que tiene DRM o que usan algún códec raro, pero ni desde Android ni desde PC ni con el VLC se puede ver.

Enviado desde mi ONEPLUS A3003 mediante Tapatalk
poison3frog le gusta esto

Por poison3frog
Novato
#86951
pues vaya... aunque no se puedan ver los canales 4k todavía, seguiré indagando a ver por qué me sale 1080p y no 4k la resolución.

gracias!

Por dr.spock
Novato
#86961
Una pregunta (que posiblemente ya esté respondida, pido disculpas de antemano, pero este hilo es larguísimo):

Estoy ya usando el addon en LibreElec sobre RPi, y aunque veo listadas las grabaciones que ya tenía hechas en la nube, al intentar reproducirlas no ocurre nada. Hay algo que se deba configurar? Qué es la opción del puerto en el addon server que viene por defecto a 0? Tiene algo que ver?

Salu2!

Avatar de Usuario
Por Mimas
Novato
#86977
vmjuidiaz escribió:Tenéis ya en Alpha la versión para Leia.
Ojo solo para instalar desde el repositorio Alpha...]

Instalado en RPI3 con LibreElec y Kodi Leia (Milhouse).
Funcionando sin problemas, al menos en las opciones de uso más frecuente.
Esto me permite compatibilizarlo con Netflix en la misma instalación.
Muchas gracias una vez más, @vmjuidiaz , por estos addons, de los que llevo disfrutando varios años, y por mantenerlos vivos y "a la última".

Por vmjuidiaz
Desarrollador
Autor del hilo
#86990
dr.spock escribió:Una pregunta (que posiblemente ya esté respondida, pido disculpas de antemano, pero este hilo es larguísimo):

Estoy ya usando el addon en LibreElec sobre RPi, y aunque veo listadas las grabaciones que ya tenía hechas en la nube, al intentar reproducirlas no ocurre nada. Hay algo que se deba configurar? Qué es la opción del puerto en el addon server que viene por defecto a 0? Tiene algo que ver?

Salu2!

¿Tienes el router de movistar o uno neutro?

Por vmjuidiaz
Desarrollador
Autor del hilo
#86991
Mimas escribió:
vmjuidiaz escribió:Tenéis ya en Alpha la versión para Leia.
Ojo solo para instalar desde el repositorio Alpha...]

Instalado en RPI3 con LibreElec y Kodi Leia (Milhouse).
Funcionando sin problemas, al menos en las opciones de uso más frecuente.
Esto me permite compatibilizarlo con Netflix en la misma instalación.
Muchas gracias una vez más, @vmjuidiaz , por estos addons, de los que llevo disfrutando varios años, y por mantenerlos vivos y "a la última".

Muchas gracias.
Algunas cosas no funcionan bien como el cambio de canal con el mando, te cambia la primera vez pero las siguientes ya no.
También se echan en falta por ejemplo el detalle de la programación que aparecía como una i en la parte baja del canal.
Pero vamos es una versión todavía alpha 1 por lo que les queda todavía muchas cosas por corregir.
Por mi parte, ya he adaptado alguna cosa como que se pueda lanzar desde la guía la visualización de un canal directamente sin entrar en acciones de cliente, pero todavía quedan cosas por adaptar.

Avatar de Usuario
Por HenryC
Miembro
#87011
dr.spock escribió:Buenas noches.

Llevo un rato leyendo todo este hilo (reconozco que un poco en diagonal) y estoy tratando de hacer funcionar Movistar TV en una Rpi 3B con LibreElec.

He descomprimido el servidor independiente para rpi en /storage/.kodi/addons y he creado el siguiente servicio en /storage/.config/system.d:

Código: Seleccionar todo[Unit]
Description=Movistar Server TV
After=network-online.target

[Service]
User=root
Group=root
Type=simple
Restart=always
RestartSec=3
ExecStart=/storage/.kodi/addons/MovistarTV.Server/Kodi_MovistarTV_Server.pvr

[Install]
WantedBy=multi-user.target
Alias=movistatv.service



Creo que además de faltarte indicar el directorio de datos como ya te han dicho, el ejecutarlo como root te puede dar problemas de acceso a las grabaciones locales desde el kodi.

  • 1
  • 354
  • 355
  • 356
  • 357
  • 358
  • 396
Temas similares
Temas Estadísticas Último mensaje
5.5.1--Guiniguada-EPG-- TVHEADEND + Movistar+ SATELITE + Movistar+ FIBRA. SOLO CANALES CONTRATADOS.
por jmcs  - 18 Dic 2017, 01:09 En Tvheadend
136 Respuestas
39790 Vistas
por josepetete
10 Dic 2018, 09:40
movistar TV en kodi
por javi323  - 04 Feb 2018, 16:37 En Windows
1 Respuestas
4017 Vistas
por HenryC
24 Nov 2018, 13:27
Kodi no carga con la Red movistar
por jlss86  - 09 Oct 2018, 01:57 En Android
5 Respuestas
1146 Vistas
por grisno
12 Oct 2018, 00:04
canales hd movistar plus para kodi
por Diegoj_69  - 19 Nov 2018, 19:48 En Guías y tutoriales
4 Respuestas
1117 Vistas
por Yorick
20 Nov 2018, 00:01
Ver Canales movistar en un linux con kodi
por estonolose  - 09 Jun 2018, 11:12 En PVR
1 Respuestas
1488 Vistas
por Tocinillo
19 Jul 2018, 11:26