• 1
  • 13
  • 14
  • 15
  • 16
  • 17
Por antekgla
Novato
#83733
Aqui te paso un link con mi log: Kodi.log

traté de pegarlo en pastebin pero excede los 512 Kb asi que no pude.

Mi configuracion del scrapper en cuanto a posters se refiere es esta:

Imagen

Los posters siguen sin aparecer.
Muchas gracias por tu ayuda!

Por pancheto
Novato
#83735
con esa captura de imagen ya te digo yo que no estás con la última versión del scraper, que oficialmente es la v1.7.6 pero en breve será la v1.8.0 (https://github.com/MaDDoGo/metadata.fil ... tag/v1.8.0). siendo así, es posible que tampoco tengas la última versión del scraper de TMDB, que es de donde se sacan las funciones necesarias para obtener las cosas de TMDB, así que si cambió algo en la web de TMDB esa será la razón de que te esté fallando.

revisando el log veo que te está buscando posters de IMDB en vez de en TMDB. y precisamente por eso te falla, porque IMDB ahora no sirve posters directamente. es más, si juntas la evidencia del log con el hecho de que las etiquetas de las secciones no son las correctas, casi mejor te recomiendo que actualices el scraper antes para asegurarte de que al menos esté haciendo lo que realmente quieres que haga. y si con la v1.8.0 aún te falla, hablamos. pero tranquilo, que seguro que al ponerle la última versión te va a funcionar ;)

Por GerarLM
Novato
#83780
Hola Pancheto,
me he actualizado a la versión que subiste a tu repo del scraper. Ahora sí que recupera información de Director pero ha dejado de recuperar FanArts.

Un saludo.

Avatar de Usuario
Por OCReactive
Novato
#83838
GerarLM escribió:Hola Pancheto,
me he actualizado a la versión que subiste a tu repo del scraper. Ahora sí que recupera información de Director pero ha dejado de recuperar FanArts.


Me pasa lo mismo, he añadido todas las opciones para obtener fanarts (de las 2 fuentes que no son FA) pero no saca nada.

Por txemix
Novato
#83922
A mi tampoco me recuperaba el fanart, haciendo pruebas con filmaffinity.xml, y sin tener ni idea, me ha funcionado comentando esta parte, que debe de provocar algún error:

Versión tal como viene el fichero:
Código: Seleccionar todo         <!-- obtención de los posters de IMDB -->
         <RegExp conditional="EnableIMDBPosters" input="$$6" output="&lt;url cache=&quot;imdb-tt$$6.json&quot; function=&quot;GetIMDBPoster&quot;&gt;http://www.theimdbapi.org/api/movie?movie_id=tt\1&lt;/chain&gt;" dest="5+">
            <expression noclean="1" />
         </RegExp>
<!-- comentado por si algún día se soluciona
         <RegExp conditional="EnableIMDBPosters" input="$$6" output="&lt;chain function=&quot;GetIMDBThumbsById&quot;&gt;tt\1&lt;/chain&gt;" dest="5+">
            <expression noclean="1" />
         </RegExp>
-->

Versión que me ha funcionado
Código: Seleccionar todo         <!-- COMENTADO obtención de los posters de IMDB -
         <RegExp conditional="EnableIMDBPosters" input="$$6" output="&lt;url cache=&quot;imdb-tt$$6.json&quot; function=&quot;GetIMDBPoster&quot;&gt;http://www.theimdbapi.org/api/movie?movie_id=tt\1&lt;/chain&gt;" dest="5+">
            <expression noclean="1" />
         </RegExp> -->

<!-- comentado por si algún día se soluciona
         <RegExp conditional="EnableIMDBPosters" input="$$6" output="&lt;chain function=&quot;GetIMDBThumbsById&quot;&gt;tt\1&lt;/chain&gt;" dest="5+">
            <expression noclean="1" />
         </RegExp>
-->


He hecho alguna prueba más y no es que la parte comentada funcione, es que la parte NO comentada, por alguna razón (deduzco sin entender el código) hace que algo falle y luego no guarda el fanart.

Por txemix
Novato
#83940
Sobre lo que he puesto antes, pues en realidad no hay que tocar nada del código, basta con desactivar la opción IMDB Posters, que por alguna razón es la que provoca algún error a consecuencia del cual no se guarda el fanart.

Por pancheto
Novato
#83986
efectivamente el problema estaba con la opción de IMDB Posters: si se activaba estropeaba toda la seccion de fanart. antes era una función tipo "chain", pero ahora es una función tipo "url". en el código cambié bien la apertura de la función, pero me olvidé de cambiar también el cierre de la misma. habría que cambiar
Código: Seleccionar todo&lt;/chain&gt;

por
Código: Seleccionar todo&lt;/url&gt;

en la línea 304 del filmaffinity.xml para los que quieran hacerlo manualmente. lo enviaré a github en cualquier caso para que todos tengamos la última versión corregida.
txemix le gusta esto

Por pancheto
Novato
#84113
se puede descomprimir manualmente sobre la carpeta userdata/addons de Kodi, pero ya está hecho el update al repositorio oficial, así que la actualización debería ser transparente para todos en breve
ronint4 le gusta esto

Por kodi_user_spa
Novato
#84131
Hola a todos,

En primer lugar, gracias pancheto por currarte el scraper de FA. Es una gozada.

Me he registrado porque tengo, al igual que he leído en este hilo, problemas con los pósters; no cargan. Me he descargado la última actualización 1.8.1 que supuestamente arreglaba el problema, pero nada.

Cabe decir que yo uso Kodi solo para ver mis películas, por tanto no he hecho ninguna modificación rara en el código ni cosas por el estilo (no soy un lince de la programación).

¿Donde puede estar el error? el scraper de FA siempre me ha funcionado bien, cargando el wallapaper, thumb, descripción de la peli, año, puntuación, póster... es solo que desde hace unas semanas el póster de la peli no carga, el resto de la info sí. Como digo, he descargado la versión más actualizada y además me he asegurado de que en posters solo está marcada la opción "posters de TMDb"

Por cierto, me pasó algo parecido en julio y lo arreglé siguiendo unas instrucciones que leí en este mismo hilo de descargar metadata.common.movieposterdb.com-1.1.3, aunque ahora no funciona...

Y ya que estamos, nunca he podido ver tráilers a pesar de tener marcada la opción de ver tráilers de FA, hay que activar algo mas para verlos? Donde se ven? En fin, esto es secundario, con poder volver a ver los posters seria ya feliz...

Ojalá podáis ayudarme :(

Edito: He estado investigando y veo que además de los posters no se me descargan los "thumb", o, como mucho, se me descarga una screenshot descuadrada. La solución a lo bestia está siendo descargar yo solo los posters de impawards y seleccionar yo la imagen... pero lo cierto es que sería mejor que cogiera los posters directamente de internet :D.

No sé muy bien como extraer el log, si es necesario porque n osabeis que puede ser el error me decis porfa.

Gracias!

Por pancheto
Novato
#84133
lo que podría estar pasando sería que la opción de descargar pósters de FA siga activada en background. no sé si hay una forma mejor de resetearlo, pero prueba a desinstalar el scraper y a volver a instalarlo, y nos cuentas.

Por manutec
Novato
#84158
Yo uso el XBMC 13.2 Gotham y he instalado el scraper 1.8.1 de FilmAffinity y al buscar la info de la pelicula me descarga el poster correctamente, pero no hace ninguna descarga de fanart, me pasa con todas las peliculas.
Ademas cuando finaliza la busqueda de una pelicula, me cambia el titulo de la pelicula a ingles y tengo que andar renombrandola de nuevo.
¿Sabeis a que pueden ser debidos estos dos problemas?

Por pancheto
Novato
#84161
habría que ver qué opciones del scraper tienes seleccionadas. tendrás activada la opción de usar título original? podrás no tener activada alguna opción de descarga de fanart?

  • 1
  • 13
  • 14
  • 15
  • 16
  • 17
Temas similares
Temas Estadísticas Último mensaje
[HILO OFICIAL] Televisores e imagen: debate, recomendaciones, etc.
por Tocinillo  - 15 Nov 2017, 13:28 En Smart TV
18 Respuestas
1057 Vistas
por mariopetit
23 Nov 2017, 15:29
Filmaffinity
por fakkaruni  - 07 Mar 2017, 20:36 En Windows
3 Respuestas
737 Vistas
por fakkaruni
12 Mar 2017, 14:10
Scraper de M3U a la biblioteca
por cere84  - 03 Ene 2017, 19:24 En Windows
2 Respuestas
492 Vistas
por cere84
05 Ene 2017, 15:54
scraper Tmdb en PVR
por keonos  - 27 May 2017, 00:27 En PVR
4 Respuestas
670 Vistas
por keonos
27 May 2017, 18:30
App oficial para iOS
por kur1oso  - 11 Nov 2017, 11:06 En iOS
0 Respuestas
264 Vistas
por kur1oso
11 Nov 2017, 11:06