Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92433
Hola os explico mi problema haber si alguien tiene alguna idea...

El sistema actual es el siguiente una RasPi 3+ conectada a la TV una Sharp aquos por HDMI en la configuración de KODI activado el passthout y de esta TV al equipo por cable óptico a un Ampli JVC y a este los altavoces 5.1 ese es el montaje y todo Ok con películas formato AC3 el ampli lo reconoce y se activa todo el audio sin problema y en el panel pone dolby d y se escucha todo Ok, si no reproduzco video alguno y estoy en los menús en el panel pone LPCM y solo se escuchan 2 altavoces (stereo). Hasta aquí todo Ok

El problema viene cuando intento reproducir un archivo de vídeo el cual contiene la pista de audio DTS, cuando le doy al play, no hay audio de ningún tipo, es como que el ampli no lo reconoce... Pero esto no es así, pues antes tenía un PC conectado por cable spdif a este mismo ampli y si lo reconoce y de hecho lo reproduce a la perfección.....

Entonces alguien sabe por qué no me lo está reproduciendo ahora, cual puede ser el motivo??

Perdón por el tocho, agradecería comentarios para poder probar, es una putada cuando descargo algo siempre he de estar mirando los formatos para que luego no tenga problemas a la hora de visionarlo, decir que me ocurre lo mismo desde NETFLIX como aplicación de la TV, lo cual me da que pensar que el problema es la TV, pero entiendo que el passthout, precisamente manda la pista de audio directa al ampli, y este debe interpretarla por eso mi pregunta por qué no lo hace???

Lo dicho gracias por leerme.. salu2

Enviado desde mi Mi MIX 2 mediante Tapatalk

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92434
Decir también que en la TV en las opciones de salida digital ya tengo puesto la opción de automático... Si no activo está opción no me funciona ni el AC3.



GRACIAS!!

Enviado desde mi Mi MIX 2 mediante Tapatalk

Avatar de Usuario
Por chenchu007
Novato
#92469
Hola,

Puede que ya esté solucionado pero, ahí va.

¿La tele reproduce DTS? Pones que un PC antes si reproducía DTS, pero cuando haces el pass-through del sonido, pasaría a ser el dispositivo que está conectado a la Raspberry el que tiene que interpretar el DTS.

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92477
chenchu007 escribió:Hola,

Puede que ya esté solucionado pero, ahí va.

¿La tele reproduce DTS? Pones que un PC antes si reproducía DTS, pero cuando haces el pass-through del sonido, pasaría a ser el dispositivo que está conectado a la Raspberry el que tiene que interpretar el DTS.
Correcto, es decir si yo desde la RaspBerry hago passthout, se supone que es la TV la que ha de reconocer ese audio o ésta al estar conectada al amplificador, sería el ampli el que lo reconocería como DTS. Es la duda que me falta por solventar y también hacer una prueba con un USB y un MKV

Gracias por la respuesta!!! Salu2

Enviado desde mi Mi MIX 2 mediante Tapatalk

Avatar de Usuario
Por chenchu007
Novato
#92479
Yo desde la Raspberry hago passtrough, pero es el Home Cinema el que decodifica el audio. Lo que no tengo muy claro es que teniendo un dispositivo intermedio entre las Rasoberry y la TV, sea la TV la que decodifique el audio.

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92480
Pero entonces, tienes la RaspBerry conectada al HOME CINEMA???

Avatar de Usuario
Por chenchu007
Novato
#92490
Si, tengo:

Raspberry => Home Cinema => TV

Con Lodi 17.6 tenía el passtrough activado para que todo lo decodificase el Home Cinema. Este sábado actualicé a Kodi 18, y no me aparece la opción de passtrough, mi salida de sonido es PI:HDMI.

Con el Kodi 17, podía seleccionar en el passtrough, que el DTS lo decodificase la raspberry. Puede que lo añadan a la versión nueva de Kodi.

Lo que me lía es que entiendo que tu tienes:

raspberi => TV => Amplificador (¿Home Cinema?)

¿Es así?

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92495
Así es....

Mi configuración es la siguiente

rBpi == TV (HDMI) == Ampli (Cable óptico)

Mi equipo de sonido es antiguo y tiene entrada SPedif / Óptico pero nada de HDMI por eso lo he de hacer así... Mi configuración de antes era un Pc que usaba KODI el audio por Spdif y el vídeo por HDMI a la TV y todo perfecto, pero ahora ha de ser así.

He estado haciendo pruebas y con archivos demo con DTS y conectado por ese cable al ampli, si que se escucha, pero por la RasPi nada! :(

Gracias por la ayuda.. salu2

Enviado desde mi Mi MIX 2 mediante Tapatalk

Por sitoriu
Novato
#92592
Yo tengo una configuración muy parecida a la tuya, la RPI (HDMI) va a la TV porque el DECO no tiene entrada HDMI y de la TV sale al DECO, el resultado es que no Lee el DTS porque para ello necesita una entrada de sonido directa desde el RPI al DECO (Prueba con cualquier otro aparato, por ejemplo el DVD si lo tienes ha enchufarlo directamente al DECO y entonces si hay DTS)y no es posible en mi caso. Me temo que no hay nada que hacer.

Si tuvieras una idea feliz compártela, please.

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92596
sitoriu escribió:Yo tengo una configuración muy parecida a la tuya, la RPI (HDMI) va a la TV porque el DECO no tiene entrada HDMI y de la TV sale al DECO, el resultado es que no Lee el DTS porque para ello necesita una entrada de sonido directa desde el RPI al DECO (Prueba con cualquier otro aparato, por ejemplo el DVD si lo tienes ha enchufarlo directamente al DECO y entonces si hay DTS)y no es posible en mi caso. Me temo que no hay nada que hacer.

Si tuvieras una idea feliz compártela, please.
Pues ese es el problema, antes tenía un PC conectado por cable Spidf al Deco y funcionaba de lujo, incluso he probado a desde un USB reproducir pistas de nuestra en DTS y el deco me lo reconoce sin problema, por lo tanto es el puente entre el emisor Rpi y la TV antes de llegar al DECO. He realizado las pruebas pertinentes con un PC y me pasa lo mismo... Creo que poco más podemos hacer.

Salu2

Enviado desde mi Mi MIX 2 mediante Tapatalk

Avatar de Usuario
Por chenchu007
Novato
#92648
Hola de nuevo,

Con la actualización a Leia 18.1, y una vez hecho un reset a la configuración de sonido, vuelve a dar opciones en el Passtrough. Se pueden seleccionar si el Passtrough se aplica a diferentes formatos de audio, a ver si tienes suerte y se te soluciona el problema. Como puse antes, dentro del apartado de sonido tuve que poner la configuración por defecto, después de eso ya me apareció la opción del passtrough, antes no la veía y las opciones eran más limitadas, aún estando en modo "Experto".

Un saludo

Avatar de Usuario
Por valsergi
Novato
Autor del hilo
#92650
Ok, gracias!! Probaré ahora cuando llegue a casa!

Salu2

Enviado desde mi Mi MIX 2 mediante Tapatalk

Temas similares
Temas Estadísticas Último mensaje
Sonido 5.1
por Ogard  - 16 Abr 2019, 08:49 En Add-ons Kodi
17 Respuestas
1591 Vistas
por DrJ
20 May 2019, 07:22
Sonido DTS MA
por Claudio Andres  - 19 Jun 2019, 09:08 En Xiaomi Mi Box (todas las versiones)
0 Respuestas
157 Vistas
por Claudio Andres
19 Jun 2019, 09:08
Sonido DTS MA y True HD
por Claudio Andres  - 19 Jun 2019, 09:14 En Audio y Vídeo
5 Respuestas
718 Vistas
por Anartzy
24 Jun 2019, 15:15
Problema de sonido
por dapesil78  - 13 Mar 2019, 16:30 En Raspberry Pi
1 Respuestas
280 Vistas
por dapesil78
13 Mar 2019, 16:31
Sonido en Kodi.
por elmaki123  - 13 Ene 2019, 00:46 En Android
11 Respuestas
1076 Vistas
por -ice-
26 Ene 2019, 13:50