Por -ice-
Experto
#77501
zakopane escribió:Si, es la RPi 3 y no se cuanto entrega el usb de la tv, pero siempre ha funcionado bien, solo desde hace unos dias le pasa eso, incluso con la nueva RPi que compré ayer mismo en MediaMarkt


Enviado desde mi iPhone utilizando Tapatalk



Un USB, si es revisión 3 entregará 900mA. Si es revisión 2 son 500 mA.
La RPi3 necesita 2A para funcionar y, si quieres que sea estable, piensa en 3A.
Y los cargadores de los móviles son PÉSIMOS. Ninguno (incluso los de Samsung y demás marcas serias) mantienen la corriente estable. Y la pequeñita es muy sensible a ésto.
¿No te parece que el problema puede estar ahí?

Por zakopane
Novato
Autor del hilo
#77502
Probaré con este que es de 2,5
Imagen


Enviado desde mi iPhone utilizando Tapatalk

Por zakopane
Novato
Autor del hilo
#77506
He estado mirando por internet y he visto que hay gente que por el motivo que sea se le acaba corrompiendo la tarjeta sd y creo que eso es lo que me pasa con la RPi.
Parece ser que la posible solución pasa por separar el sistema de archivos y sacarlo de la SD para ejecutarlo en un disco duro externo y de esa manera acabar con el problema de daño de la SD, o sea dejar la particion de arranque en la tarjeta, y en una memoria externa la particion raiz.

Avatar de Usuario
Por Zeoka
Novato
#77507
zakopane escribió:He estado mirando por internet y he visto que hay gente que por el motivo que sea se le acaba corrompiendo la tarjeta sd y creo que eso es lo que me pasa con la RPi.
Parece ser que la posible solución pasa por separar el sistema de archivos y sacarlo de la SD para ejecutarlo en un disco duro externo y de esa manera acabar con el problema de daño de la SD, o sea dejar la particion de arranque en la tarjeta, y en una memoria externa la particion raiz.

Apagas la rpi en algún momento?

Enviado desde mi MI 5 mediante Tapatalk

Por zakopane
Novato
Autor del hilo
#77509
Cuando empieza con los cortes o cuando se queda bloqueada le quito la alimentación porque es imposible apagarla de otro modo

Avatar de Usuario
Por Zeoka
Novato
#77512
zakopane escribió:Cuando empieza con los cortes o cuando se queda bloqueada le quito la alimentación porque es imposible apagarla de otro modo

Y cuando apagas el televisor se queda encendida?

Enviado desde mi MI 5 mediante Tapatalk

Por -ice-
Experto
#77524
zakopane escribió:Probaré con este que es de 2,5
Imagen


Enviado desde mi iPhone utilizando Tapatalk



El SO se daña por apagar la RPi a lo bestia. Si lo apagas como corresponde no tendrás problemas.
Consiguete una tarjeta Clase10 de 8Gb y monta ahí.
Existe un listado con las mSD que funcionan bien con la RPi3.
¿Has probado ese adaptador?

Por zakopane
Novato
Autor del hilo
#77527
He probado el adaptador pero no funciona bien, probaré lo de la mSD


Enviado desde mi iPhone utilizando Tapatalk

Por zakopane
Novato
Autor del hilo
#77550
Parece que el adaptador no iba bien pero al final ya va.
La RPI no ha dado problemas en toda la tarde y parece ir bien (de momento).
Mañana compraré un hub usb con alimentación para poder conectar algunos dispositivos a la RPI y he desactivado algunos addons que cuando los intentaba desactivar anteriormente siempre me fastidiaban la tarjeta.
Seguiré trasteando e iré exponiendo mis impresiones.


Enviado desde mi iPhone utilizando Tapatalk

Por -ice-
Experto
#77559
zakopane escribió:Parece que el adaptador no iba bien pero al final ya va.
La RPI no ha dado problemas en toda la tarde y parece ir bien (de momento).
Mañana compraré un hub usb con alimentación para poder conectar algunos dispositivos a la RPI y he desactivado algunos addons que cuando los intentaba desactivar anteriormente siempre me fastidiaban la tarjeta.
Seguiré trasteando e iré exponiendo mis impresiones.


Enviado desde mi iPhone utilizando Tapatalk



Hay un detalle con los hub USB que, de normal, no se tiene en cuenta.
Cuándo el hub es autoalimentado y su diseño no es el correcto, por el conector USB que se enchufa en este caso en la RPi, se está enviando tensión HACIA el puerto USB de la RPi. Esto no debiera ser así porque se están saltando las protecciones de la línea de entrada.
La forma de comprobarlo es conectando el hub a su fuente de alimentación y al USB de la RPi. Luego, desconectar el microUSB de alimentación de la RPi. Si no se apaga, está recibiendo tensión desde el USB. En ese caso tocará desarmar el hub e interrumpir el circuito de alimentación hacia el conector USB.

Por zakopane
Novato
Autor del hilo
#77740
Parece que ya se han resuelto los problemas de cortes. El problema venia de la micro sd, que de apagar la RPI quitando la corriente se acaba corrompiendo y por mucho que intente meter el SO del backup que tengo guardado o incluso metiendolo nuevo siempre acababa en microcortes o bloqueos.
Lo que hay que hacer es primeramente reparar la micro sd, no vale solo con formatearla y una vez reparada meter el SO y ya no vuelve a fallar.
Muy importante apagar siempre la RPI a traves de software y luego quitar de la corriente. Tambien alimentarla con el cargador y no a traves del usb de la tv porque siempre que apaguemos la tv cortariamos la corriente de la RPI apagandola mal.


Enviado desde mi iPhone utilizando Tapatalk

Por -ice-
Experto
#86089
El USB V.3 entrega 900 mA cómo máximo. Una RPi3 necesita 2A al menos para mantenerse estable. ¿Y todavía se preguntan porqué no funciona?
Que haya funcionado alguna vez no significa que lo haga siempre. Posiblemente arranque y puedas moverte por los menús, pero en cuánto le pidas un poco de chicha al procesador se irá todo a tomar por culo.
Es tan simple cómo alimentar a la RPi con una fuente de alimentación que entregue la corriente que requiera y que no se quede corta (ésto se puede entender cómo que debe estar generosamente sobredimensionada o usar una de probada calidad, lo que ya es más difícil).

Temas similares
Temas Estadísticas Último mensaje
Cortes en la emision de series o peliculas
por elteki  - 20 Feb 2018, 13:35 En Android
0 Respuestas
52 Vistas
por elteki
20 Feb 2018, 13:35
Cortes en la emision de series o peliculas
por elteki  - 20 Feb 2018, 13:34 En Android
6 Respuestas
209 Vistas
por nickmers
21 Feb 2018, 12:44
Tvheadend 4.2 en Raspberry Pi 3!!!
por ChicklePega  - 07 Oct 2017, 14:27 En Raspberry Pi
8 Respuestas
1073 Vistas
por araetamae
15 Feb 2018, 12:59
Android TV en Raspberry Pi
por fernando2304  - 25 Abr 2017, 11:21 En Raspberry Pi
1 Respuestas
989 Vistas
por -ice-
13 Feb 2018, 13:52
Arrancar Raspberry con usb
por Ambit  - 25 Nov 2017, 09:17 En Guías y tutoriales
0 Respuestas
324 Vistas
por Ambit
25 Nov 2017, 09:17